V7 Layout Technical does not hide objects behind other surfaces

In V7, Layout Technical is behaving more like Wireframe. Objects behind other surfaces are showing through the foreground objects. The problem occurs in the screen view and on the printed document.

You will also notice that in V7, the background in the 6 Technical Details at the top do not display with the normal shaded Technical background. The background is the same as for the 3 lower Wireframe Details.

I opened the same file in V6 then in V7 without any changes and without saving.

Regards, Garry.

Rhino 7 SR1 2020-12-2 (Rhino 7, 7.1.20337.05001, Git hash:master @ 5c341516d2f548c8e4859a9aed89600f09c5203a)
License type: Commercial, build 2020-12-02
License details: Cloud Zoo

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 4-11-2020 (M-D-Y).
Primary OpenGL: NVIDIA GeForce RTX 2080 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 1-31-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.23

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-31-2020
Driver Version: 26.21.14.4223
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.1.20337.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.1.20337.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.1.20337.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.1.20337.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.1.20337.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

V6…

V7…

Hi Garry -

It looks like you have modified the display mode settings in Rhino 6 and have not done that in Rhino 7.
Look at the Rhino Options > View > Display Modes > Technical page under Viewport settings > background and Visibility > Show hidden lines.
-wim

Hi Wim. I have disabled Show Hidden Lines and that solved that problem. However, I cannot find any difference between V6 and V7 settings in relation to the background.

Regards, Garry.

V6…

V7…

An hour or so later…

I am beginning to think that the white background on the display of the Technical Detail was a gremlin in V6. I adjusted the background colour for Technical in V7, and it only displays that colour when the Detail is activated.

However, I now have an interesting twist. The Show Hidden Lines setting is no longer available, and the lines are now showing through on the Technical Detail again. Many new options have appeared, mostly highlighted in purple. I do not know how that has happened. As I recall, the only thing that I did was to experiment with a solid colour for the Technical Background, then set it back to Use Application Settings. The Technical panel now looks similar to the Shaded and other panels. It appears that there has been some confusion in the available items for selection.

No Rhino upgrades have been applied in the meantime.

Rhino 7 SR1 2020-12-2 (Rhino 7, 7.1.20337.05001, Git hash:master @ 5c341516d2f548c8e4859a9aed89600f09c5203a)
License type: Commercial, build 2020-12-02
License details: Cloud Zoo

Hi Garry and Wim,

I have the same issue, no option to show hidden lines in technical view.
Is there a solution at hand?