V5 Rendered Display Mode: How to turn the default lighting off?

Hi there,
I can`t find the answer in help topics so decided to ask here…
How to turn the default lighting off in Rendered Display Mode?

  1. I`m adding 1 or 2 lights (spotlight or directcional light, for example)
  2. Lighting method in RDM options is set to “Scene Lighting”
  3. In viewport with RDM enabled I see effects of my lightings and default lighting too.

I thought that when I placed my custom light into scene the default one was off automatically. But it looks like I`m wrong.

Please can anyone explain me how to get rid of the default Rhino 5 lighting in Rendered Display Mode?

This is correct. The light you see is “Skylight” that is on by default. If you turn skylight off and remove all your lights, the default light will be turned back on.

Sorry, I was talking about Rhino 6.
Can you upload your model and export your Rendered display mode for me?
(Go to Options > View > Display Modes, select Rendered, and click “Export”.)

Hi, Kelvin! Of course…

22_90.rar (19.6 MB)

Rendered.ini (10.4 KB)

EPS 1 (plintus).rmtl (1.3 MB)
And here is also the material assigned to the model…

By the way, I “played” with all types of lighting method, in Rendered Display mode with some custome lights on but any selecteed type doesn`t affect on lighting effect at all.

In Shaded Mode that works, in Rendered Mode it does not…

If you check “Enable diffuse lighting” in the material, you would see adding lights removes the default light.

What do you want to do by the way?

When “Enable diffuse lighting” is unchecked, lights have no effect to the material/object in Rendered display mode.

Thanks, Kelvin, i’ll try this tomorrow when back to the office. I hope it will help to solve my little problem. I just wanted to get fast rendered screenshots of the plints model with eps texture without any real rendering. I have to get hundreds images of that kind and have no time to render all of them one by one. Screenshoting seems to be the optimal choice if I only could set it up correctly.

1 Like

Hi Kelvin! Ive tried your advice out and found that it could work properly only when an environment in material properties tab was unchecked. ![image|146x500](upload://53DLHk0iE5nF2SpfNO2g79Udexf.png) So I think Im currenntly starting to understand the meaning of the environment. Is this a kind of matcap? So when its checked all custom lights do not work. And I used it by mistake as an extra texture to colorise to the model. So it seems that I cant complete my task just with Rendered display mode:disappointed_relieved:

The Environment in materials is used for “fake environment reflection”. It is not as realistic as “raytraced reflection”, but it is also useful in some cases.