V-ray Dome HDR ground plane reflection off

unhandled

#1

Hi!
Thinking to move to V-ray 3 for Rhino and now testing trial.
How to turn off ground plane dome hdr reflections? I still want my model to have environment reflections.
I tried google and forum search but I did not find solutions.

I wish you to take screenshots of settings to get to the result.

Thank you:
Wagner


(Marc Gibeault) #2

If I understand correctly your question, you could change some parameters in the ground plane.s material so it does not reflect the HDR.


#3

Hi Marc!
Thank you for your advice.
Unfortunately I did not get changes to that. I tried 0 and 2 but nothing changed…
More advices anybody?

:slight_smile: Wagner


(Travis Serio) #4

Set the background override map to a solid color. Also… if i remember correctly if you’re using GPU you might need to use CPU for this feature.


#5

Hi Travis!

Thank you for your help. Can you please take a screenshot where and how to change it black. I’m not so familiar with this…

Wagner


(Travis Serio) #6

Hi @Wagner

Sure no trouble at all.

First make sure you have the engine set to render using CPU and not GPU as I just confirmed that this won’t work with GPU yet.
0625

Next open your ground plane material and set the Environment Overrides - Background check box like you had in your image you posted.

Next click the checkerboard box (the map slot) off to the right of the slider for Background.
0576

When the dialog pops up asking what type of map channel you’d like select Color and choose the color you’d like to use as the background.

You should now get the following result.

Without

With


#7

Hi!
Thank you for your great step by step advice! I made it like that but no results like you have…
Please check attachment file…

Wagner

ground reflection.3dm (1.1 MB)


(Travis Serio) #8

Your problem is that you’re using a dome light with a map. The reflection exclusions only ignore the Environment channels, not physical light channels.

Remove your dome light and apply your sky hdr to the v-ray options - Environment - Background.


#9

Hi Travis!
Nice to hear and learn why it did not work. Thank you very much!
I feel Vray has great “customer support”! I really appreciate your help!

If we will see some day, I’ll order a beer for you :wink:

Wagner


#10

One more thing about this. How to get environment invisible from the background? I tried to change setting in environment but did not get results… Pictures you sent, there is sky background visible…
When I used dome with hdr there was setting “invisible”…


(Travis Serio) #11

it sounds like you’re better off taking the object that you want to have sky reflections (cube) and add your sky to that materials background vs trying to have everything in the scene ignore the background accept 1 object.


#12

Might be that you are correct. But in real life there is a lot of parts in assembly… Then I have to make it to all (15 pcs) materials. But in any way, thank you for your great support!

Wagner


(Travis Serio) #13

A very simplistic approach is to just save the render as a PNG and the environment background will be transparent. You can then composite onto any background you’d like.


#14

Thank you everybody! I really appreciate your help <3

Wagner