UV Editor question

I have a single error-free mesh.

Now I want to apply a mapping to it.
First I unwrap the object, Method=Conformal.
Then I go to the UV Editor.

I get a mesh which is very dense in the middle:

The mapping is not nearly even.

To get the mesh more evenly, I tried some of the UDTs like _CageEdit, _Stretch etc…
Doesn’t really work well.

Any ideas?
Or a different approach?

KillMe.stl (591.6 KB)

The best person to answer is probably @Jussi_Aaltonen

hi @Charles if a seam is allowed, you will get better symmetry and less deformation:


KillMe_re1.3dm (981.8 KB)

or only one seam:


KillMe_re2.3dm (4.4 MB)

1 Like

Thank you @Gijs

I tried myself by splitting the mesh and join it.
So I should have 2 seams.
Yes, I have and UnWrap goes well.

Then I tried with 1 seam only.
Also works well.

To select 1 seam only is cumbersome.
The chain option while selecting the seam is useless.
In the end I selected both seams by window, and then Ctrl-windowed the unwanted one.
I’m sure you know a smarter method?

that was my method too

Not really, but what works partly is QuadrangulateMesh, then you only have to double click a couple of edges.