UV Editor - Meshes not visible unless selected RH6

Hey guys

Just watched Tutorial on TextureMapping (https://vimeo.com/268449998)

When I do it, I can’t see the meshes in the UV Editor on top of the texture. I have to blindly select the meshes, which means I can’t do detail business I need to do in UV Editor. I’m using Rendered viewport mode (default version of it) and tried Wireframe mode. Both in Top and Persp viewports.

Rhino 6 SR7 2018-7-29 (Rhino 6, 6.7.18210.11281, Git hash:master @ f815aae129dfe2008152736625ca2dbd0036b29a)
Licence type: Commercial, build 2018-07-29
License details: Cloud Zoo. In use by: Alan Farkas ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-NUQN85K

GeForce GTX 980 Ti/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.35)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-23-2018
Driver Version: 23.21.13.9135
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.3.1.650\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2017.10.16.484\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

Does it still happen with this plug-in disabled?

Yes, it still happens

With an unwrapped _MeshBox I see this in the UV Editor. Can you post a screenshot of what you see?

Do you have any of your Rhino appearance colors changed from their defaults by any chance?

edit: I can make them disappear, but that is something one has to deliberately do.

Here I have set the viewport background color to white for wireframe, set the layer color to the same white. Solid white for background color in Rendered mode as well (render settings). Now the UV mesh is invisible, since the edges are colored the same as the background. Is this what is happening for you?

Here’s what I’m looking at

HI @Alan_Farkas, you might try 2 things:

  1. turn OFF the groundplane
  2. for your current viewport display mode, Enable “Mesh Wires” in the display tab

any better ?
_
c.

You had me excited, but nope. Same.

Please post a screenshot of your model with:

  • Shaded dispay mode enabled
  • the Display tab open, Mesh Wires ON
  • the UVEditor active after picking the rectangle
  • nothing selected

Also if you run the command _ShowRenderMesh, select eg. a nurbs sphere, do you see the wireframe of the mesh sphere ? (Use _HideRenderMesh to turn it OFF)

_
c.

btw. in your screenshot i do not see the _UVEditor dialog. Do you have “Show Wireframe” checked ?

_
c.

Fixed. Weird. I set my “shaded” display mode back to Default, and nothing thatdidn’t do anything.
But when I set my Wireframe back to Default, I could suddenly see what I needed to in both the tpo-view Wireframe viewport AND the Perspective Shaded Display.

Thoughts?
thx

No, if you would have saved the display mode before resetting it it would have been possible to find out which setting you canged. But since it is fixed there is no need for further investigation i guess.

_
c.

:sunglasses: True

This happened to me as well. By changing a wireframe mode back to default solves the issue. Thank.