Rhino6 visualization bug - extrusion/surface dissappearing when clipping plane is present

Rhino 6 SR15 2019-5-28 (Rhino 6, 6.15.19148.13161, Git hash:master @ ae191a06e4addc9964c3f4231a3312f38d4153d0)
License type: Commercial, build 2019-05-28
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: 9YQZKB2

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 5-5-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.64

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-5-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

When i have a clipping plane in my model, the extrusion that i have just created disappears from display, it will still show as selected and will flicker some when the model is rotated but when the clipping plane is turned off, it appears again. The clipping plane is not “in-plane” with the newly created extrusion but it acts similarly as if it were.

UPDATE: When exploding the extrusion into surfaces, it has similar behavior but in reverse of previous behavior…the surface disappears from view when clipping plane is selected.

The behavior also applies to curves.

When pointcloud file is turned off from visibility, the extrusions/surfaces are displaying correctly.

Any ideas @pascal ?

Video card drivers up to date, windows update up to date. Issue only arises when clipping planes and pointclouds are together, but that is a really big issue because thats the majority of what we work with.

Hello - no ideas yet - I am making a file to try to reproduce the problem…
What is the display mode, or does it matter?

So far, looks like this:

My pc is not vast - 1.3 million pts- is that part of the condition? Does it do this with any point cloud or just huge ones?


Shaded and Ghosted are the two display modes i use most often with Pointclouds. I dont know how many points are actually in my PC, (is there a command to quickly check?),

If you give me the link to upload my files i can send them to you for you to check.

I havent noticed it in other model files with pointclouds yet.

Hello - the What command will tell you about the point count. Please SaveSmall, Zip, and upload (preferably the most minimal file that shows the problem) here, to my attention:



I uploded it. Had a system crash, 3rd this week…a bunch since running RH6…dont know if its related but i cant get it to recreate on demand, only in the most inconvenient times. If i can get a repeatable occurrence i will post it.

Hi Mason - I have your file, and… it looks fine here, clipping plane or not. I am seeing if one of the other techs has a GTX 1070 wired up…