User text attribute window empty when Human UI is on


I had a turn on the forum and didn’t find any information about it, so decided to create a post
When I open a gh file containing some Human UI the user text window are no longer shown in Rhino.
there is 2 different scenarios

1- I create a point, look at the attribute open the human UI file, user attribute on the point are still there.

2- I create a point, open the Human UI file, then try to have a look at the attribute, they are all gone…

after some (a lot of in fact) research I find with the test file below that it can come from the listener button, as long as it is disable or suppress the user attributes no longer disappear… (25.3 KB)

any help or solution ? is that known ? can it come from Human UI itself ? a compatibility with an other plug-in ?
I’am thinking about replace all the button by a rhino command button sending True…

I don’t think the button has anything to do with it. I suspect there’s some conflict happening involving WPF. If I open the usertext panel before launching human UI, everything works as expected; if I launch Human UI before viewing the panel, it comes up blank. Do any McNeel developers have any insight here? I’m happy to modify Human UI to fix this issue if necessary but I’m not even sure where to start.

I have the same problem. Is there anything new about this?

Hi @andheum, @wim (Don’t know who to tag from McNeel Developers)

This still seems to be an issue, that if you run a code using HumanUi then the User Attribute Panel is blank as in the original post, this does not seem to be just happening on this thread, see also this tread.

Any updates on this?

Hi Matt - no updates on this one, AFAICT.

I’m not able to reproduce that issue here with the gh definition that was provided in the first post of this thread.
Which SR and SRC of Rhino are you all running? Is anyone using a 3Dconnexion 3D input device?

Using Rhino 6 SR20

Only happens when i run the GH code with the Human UI nodes in first after opening the files and not looking at the user text for an object before hand.

Can’t post this exact file but can look at making a demo file with the issue if required.

A demo file with fewest possible components would be good, yes.

Just trying to weed out things, do you use a 3Dconnexion device?

Also, please update to the latest Rhino 6 SRC 22 as that, so far, sounds like it has possibly solved a blank panel for a different user.

This is still a big issue for me in V7sr4.
It even causes a crash in my case.

And here’s the “RhinoDotNetCrash” dump :

RhinoDotNetCrash.txt (6.9 KB)