Upload not working

Hi everyone,

While I was trying to upload a new GH definition i realised that for some reason, it is not working. After publishing, having the GH def checked & validated, it is loading all the parameters and everything but the rendering viewport is stuck on Shapedivers Logo.

Even if i click to “Apply settings” and try to access the Def from the Dashboard menu, it will behave just the same. It will just display the Shapedivers logo.

It is not that i’m testing anything completly new, just a couple of code updates.
I’ve also tried to upload older definitions that are currently working, but without succes, having the same issue.

Could you please check what is going on with the upload feature?


It would be great if you could share a minimal version of the definition replicating the issue. I just tried uploading a model and it worked for me.

Do you use any plugins? We have just rolled out an update for some plugins so I’m wondering if this is correlated.

Hi Pavol,

I can’t post a minimal version, there is a lot of stuff going on inside…
I could split it in several parts, but would take a lot of time…

Is there a way you can have access to the definition by using the e-mail of the account?
How can i send it to you as a DM?

As I said, it used to work just fine some days ago.
No major updates nor changes have been included rather than a couple of values since the last upload.

About the plugins being used:
· Heteroptera
· Weaverbird
· Lunchbox
· Squid
· Pufferfish

Is there a quick way to check which plugins are being used in a certeain Gh def?
Just to make sure im not forgetting any!

Thanks in advance Pavol!

You usually get an error message while processing the model if there is problem with plugins. The stuck viewer with the logo suggests that there is no geometry to render. Are there any objects visible when you upload? Could you also check your browser console for errors?

To see plugins used in the definition, simply save it as .ghx, then open it with a text editor and search for GHALibraries. Keep in mind that the version numbers are from your local plugins and not those installed on ShapeDiver.

Reviewing whole Grasshopper definitions is outside of scope of this free public Forum. If you are interested in private support contact sales via the contact form at www.shapediver.com.

Hi @pavol

I hope i didn’t sound like “review my defintion and fix it” since this wasn’t my intention, but you suggested sending a minimal one, and there is no minimal definition i can send but the whole project.
I know it worked and it should work.

As I mentioned earlier, even uploading the same definition that was working a week ago, whithout performing any changes in it, won’t load. So it is not a matter of my definition, but something that has probably been changed, updated or whatever from your side…

· Im not getting any error while processing the model.
· There is geometry to render.

About the plugins used, i’ve just checked it and i was missing Human.

Let me know if i can do anything else to help you diagnose the issue.

I’m really sorry for the inconvenience.

It would really help if you could narrow down the definition and share it in this thread. I can then review it and help quickly. I’m sure your project is well organised so you can delete some parts and isolate the bits that cause the upload issues.

However, the definitions are uploaded and I can access to them through my accounts Dashboard.
I mean, it is not that they are not uploading at all, they pass all the checks, and i can press the “apply changes” button…

The weird thing is that while i can get into one of my previous reviews (lets say v10) from the dashboard, everything loads fine, parameters, rendering viewport…

But, if i upload that same v10 def now (0 changes exact same file), the rendering is stuck on the logo, even if i access to it though the dashboard (afer uploading and so on).

Is that some helpful info?

I’ll try to make some chops and test parts of the def separately… But i still think that is not the issue


@pavol I’ve just checked my dashboard again, and for some unknown reason, the definitions that weren’t loading they now load (0 changes on the code).

There is however something weird i noticed:

· These 3 defintions are exactly the same.
· None of them were loading and were stuck on the logo.
· Haven’t updated them, you can check the upload date if you want.
· None of them was even showing a preview @ the dashboard.
· I’ve just went in again after ~4 hours and they weren’t showing a preview either.
· Launched one of them, and it now loaded just fine.
· Saved the changes, and now you can see the preview (blurred it out because of the forum)
· The others now load too.

Could it be related to some server maintenace you were performing?
Or the update on the plugins you mentioned?

No changes had to be done, but everything is fixed now…

Hope that helps!

@s.armas Thank you very much for your observations, this definitely helps. We are investigating further and I will get back to you once we know more.

@s.armas I just wanted to double check that your models are OK. An unexpected glitch occurred yesterday but all my models work fine now. Please let me know if you have any issues.

Hi @pavol,

It seemed to be working fine last week, but i’m experiencing the exact same issue today…
Could you please let me know for how long are we going to experience this issues?

@s.armas all issues with the recent plugin updates have been resolved last week and models with plugins work fine now. I’m wondering if your model hits the computation time limits only with some parameter combinations. This can lead to seemingly unpredictable behaviour and following post explains why this happens.

Review your Grasshopper definition and optimise if possible to keep it safely within the computation time limits, see tutorials below for more. I hope this helps and let me know if you have any questions.