Update minimum requirements for Rhino 7

So I just had a chance to test the minimum requirements for Rhino 7 and I can say they are too low.

We need a small PC next to our laser cutter in the workshop that just needs to run Rhino 7 and the Laser software. As the workshop is quite dusty we were looking into small fanless or “industrial” PCs. We bought one that we assumed would be sufficient with the specs:

Intel Celeron-Prozessor J4125 (up to 2.7 Ghz, 4-core)
Intel UHD600 graphics
8 GB Ram
m2 SSD

Well, I can report back that Rhino is totally unusable.

It was a completely fresh install only installed Rhino, ran it and opened a file. At first Rhino wouldn’t even load properly, all viewports remained black.

I opened a Rhino file which contained just a bunch of meshes and the viewport refresh rate in wireframe mode was less than 1fps.

Is it purely the Intel Graphics?

Needless to say we are returning the PC and getting something beefier.

Hi @seltzdesign

Yes, most likely. Rhino 7 does NOT like those integrated graphics. Did you make sure that the drivers for the Intel UHD600 are the very latest? The black viewports often indicate that the drivers are out-of-date. I’m running Rhino 7 on my 6-7 year old laptop with no problems.
HTH, Jakob

Hi Armin -

From Notebook / Laptop Reviews and News - NotebookCheck.net

Due to its lack of dedicated graphics memory […]

The System Requirements page state:

  • 4 GB Video RAM or more recommended.

You tried a PC with 0 GB VRAM so you went quite a bit below the recommendation here.
-wim

In the device manager the UHD600 was shown with 1GB.

The drivers were up to date according to windows update.

So the slowness of Rhino is purely because of the graphics card memory? I would assume that 1GB would be sufficient for the scene I was loading which contained maybe 20 very low poly meshes.

Enabling the Gumball alone took like 3 seconds.

@Normand what graphics card do you have in your old laptop?

I guess I will look for an older PC, but with dedicated graphics then.

The recommendation for 4GB per screen is being really conservative, but 1GB of shared memory is definitely not enough for all the buffers and crap involved with 3D graphics, and it’s using regular RAM instead of VRAM which is a lot slower, and 8GB RAM is barely enough to operate a Windows computer without a gig being used for video. On top of that Intel integrated graphics are garbage even when they ‘work.’

Don’t trust windows update! :grimacing: Start Rhino and run the SystemInfo command. If the driver date is more than ~6 months old, check the appropriate (in this case Intel’s) website for an updated version. There’s also the Notofications tab (The blue bell), where Rhino will (try to) warn you about outdated drivers.
image

My old laptop is a dedicated (but very old!) Nvidia… Don’t remember the model, but it’s a medium 9XX-model. It was actually a little lame, even when I bought it! :joy: Maybe 940M, but not sure.
-Jakob

Thanks for the tipp. I have already packed up the PC now. If it is THAT slow with old drivers, I don’t know what updating them is going to improve.

You’re right. I didn’t think that Rhino was that heavily reliant on GPU power.

In that case, no fanless PC will be up to the task of running Rhino.

Looking at this HP Elite Desk 800, which costs more than double, but at least is a small form factor. It has a GTX 1660 Ti with 6 GB of video memory. Let’s hope that is barely enough to run Rhino :stuck_out_tongue_winking_eye:

or maybe this small Dell Precision 3240 CFF with a Nvidia P1000 with 4GB, although that would again be at the low end.

I’m not sure. Sometimes I use Rhinoceros over Remote Desktop (MSRDP, solely software-level graphics) to show my colleague something. The performance is bad but not that bad, which is still usable.

This is a situation…oh as Keyu just said, where using the fanless machine to remote to a virtualized desktop or something might be a good solution. There are options that work a lot better than Remote Desktop, mind.

Yeah, I thought of that too, but it doesnt make sense in our case. The software needs to run natively, because the pc is hooked up to the laser cutter and you just want to be able to open a rhino file, “print” to the laser and then leave the jobs running.

The PC is running the whole time the laser cutter is running, which might be days on end. So we want something that can work on its own and you can leave running for basically ever and it doesn’t use a ton of electricity needlessly and isnt a big box with fans collecting dust.

I just tested with my laptop and dedicated graphics card disabled. Viewports aren’t black. Speed is quite OK. Just Intel 630 (1GB) with very old driver. So I doubt something else is wrong.

Computer platform: LAPTOP - Plugged in

Non-hybrid graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 7-24-2017 (M-D-Y). OpenGL Ver: 4.5.0 - Build 22.20.16.4749
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
NVIDIA GeForce GTX 1050 (NVidia) Memory: 2GB, Driver date: 12-11-2018 (M-D-Y).
> Integrated acclerated graphics device (shares primary device ports)
- This device is not being used

Ah, this is with Rhino 6. Can you test with Rhino 7?

Looks OK. I can clearly see the usage of Intel integrated graphics went to 80% during TestMaxSpeed. Not to say the resolution is 4K.

Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13001, Git hash:master @ aa7902c94c5aa33511e60d30f82b636be43bc85f)
License type: Commercial, build 2022-03-08
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in

Non-hybrid graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 7-24-2017 (M-D-Y). OpenGL Ver: 4.5.0 - Build 22.20.16.4749
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
NVIDIA GeForce GTX 1050 (NVidia) Memory: 2GB, Driver date: 12-11-2018 (M-D-Y).
> Integrated accelerated graphics device (shares primary device ports)
- This device is not being used

ATTENTION:
No graphics device is being used. Either an error occurred on startup, or certain devices have been disabled.
See below for any possible configuration changes that may help resolve this issue.

  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

Vendor Name: Intel
Render version: 4.5
Shading Language: 4.50 - Build 22.20.16.4749
Driver Date: 7-24-2017
Driver Version: 22.20.16.4749
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

What’s interesting: if I just draw 2 cubes and run Testmaxspeed I actually get like 177fps in Rhino 7 and 123fps in Rhino 6. But as soon as I open a file that contains some proper geometry, like a few thousand instances of cubes and a few low poly meshes, the frame rate drops extremely. To 0.48 fps. Meaning it is almost 370 times slower!

Just 2 boxes in Rhino 6:

Larger file in Rhino 7:

Same file, same version of Rhino 7, bigger machine with RTX2070:

That means that a larger file slows down the graphics extremely, probably as it exceeds its available memory.

What I also noticed is how much the grid can slow down the viewport. I would guess that the grid is literally just lines it draws, but does not use instancing. Also it seems like Block instances don’t use instancing in the renderer, otherwise drawing one or drawing 5000 should not make a significant difference.

Oh I think I might have found why it is so slow:

Somehow in this file it managed to get the Grid to extents of 100.000 even though the maximum is 10.000.

On my fast machine:

Grid on = 17 fps
Grid off = 60 fps

On the slow machine:

Grid on = 0.5 fps
Grid off = 5 fps

@wim Do you know if the Grid is somehow optimised for fast rendering or is it literally just drawing 200.000 lines in the case above?

-wim