Unroll 3d model with texture

Hi Clement - yeah, same problem, but I tried to solve it somewhat in reverse to what you did - I made one segment, and rotated the mapping widget 45 degrees at a time, meshing and squishing at each rotation - it worked fine for all but one - on that one, (where the mapping seam is on the edge of the slice) , the squished mesh is completely out of whack along that edge

So, evidently, the mapping affects the squish process… ?

-Pascal

Somehow yes, but this something i guess @dalelear knows about. I’ve found that in case of surfaces, the parameterisation does affect it too. What really bugs me is that it requires meshes just to get the resulting texture right. This should flagged as a bug.

c.

Indeed… https://mcneel.myjetbrains.com/youtrack/issue/RH-37283

-Pascal

Thanks a lot for all. It work from clement link.

Hello.
I continues in this topic. I have a problem. I want to print but rendering me strangely renders. What’s the problem?

And after rendering:

What happen? Mayby I do somthing wrong?
UnwrapEarth-maciek.3dm (2.8 MB)

Hi Maciej - I think maybe you assigned spherical mapping to the meshes, not to the surfaces before creating the mesh - is that possible? (no surfaces in your file). Try applying the spherical mapping to the surface, then Mesh, and Squish the results without doing anything more to the mapping.

-Pascal

Hi Pascal.
I do it like that:

  1. Create a vertical half circle and select it
  2. Use _Revolve, enter 0 as start angle and 360/12 as end angle
  3. The result should be one of 12 segments of your nurbs sphere
  4. Use _ArrayPolar, pick the center and enter 12 to create a full sphere made of 12 segments
  5. Join the segments into a single polysurface, this is your sphere
  6. Assign a spherical mapping to the sphere and a texture map like the one attached below
  7. The sphere is now mapped spherically and ready to be flattened
  8. Create a mesh from the nurbs sphere, use the command _Mesh
  9. Explode the resulting mesh into its 12 segments, hide or delete the nurbs sphere
  10. In my example i´ve named the segments S1 to S12 to not confuse things
  11. To unwrap with retained texture assignment, i´ve used the _Squish command with these settings:
    SplitSeams=No
    PreserveBoundary=Yes
    Deformation=Free
    Material=Rigid
    Outside=Up
    Decorate=No

Mayby you check me. Its new file.

I first assigned spherical mapping surfaces and then I do mesh.

unwrap.3dm (2.6 MB)
.

1 Like

Yeah… - I see that I get the same results on my file from yesterday - I tested in V5 and V6, and they have exactly the opposite problems - V5 display is correct. rendering is not, and in V6 the display is wrong but it gets the rendering correct.

Also, I see that I accidentally set PreserveBoundary to No on my bad attempt yesterday - if I set that correctly all of the slices squish nicely with texture. But, apparently you need to render in the V6 WIP, not V5…

-Pascal

Awesome topic !!!

I’m working on exactly this project but instead of sphere I got hot air balloon (H 12 meters). The object is huge and my graphic has size of 31,6 m x 16,5 m 72 PDI. I really hope I can insert such huge texture (not finished yet) in Rhino.

Is there a known size limit for textures in Rhino I should respect?

Thanks for helping!

Do you mean 72 dpi? Is your graphic going to be 31.7 Giga-pixels? Or will it be lower resolution and “upscaled” for printing at 72 dpi? What will be the actual resolution of the base graphic?

Hi Alex,

There is absolutely no way you need 72dpi for something that big. You’d easily get away with 5dpi. Have a look at a billboard up close one day.
As a rule of thumb, the minimum viewing distance, which allows the whole image to be viewed in its entirety, can be calculated by multiplying the length of the diagonal of the item by 1.5.
Then use this handy table to work out the required dpi for continuous tone (ie. photographic) images
viewing distance-ppi

If you have vector art or text that needs sharper edges, then you are going to have to map that to your balloon then flatten that separately. Then colour that in Illustrator and assemble the whole horror show in InDesign.

Regarding texture size limit. That is mainly a hardware limit depending on the amount of VRAM in your video card.
If you go Tools>Options>View>OpenGL it will show you the max texture size in pixels you can use. Note that Rhino doesn’t report Vid memory over 4GB for some strange reason.

If you can’t fit your graphic into those limits, then look at multiple UV sets and deal with it that way.

Obviously there is a lot to this, but hopefully that gets you pointed in the right direction.

Steve

2 Likes

Thanks Steve,

I managed with the image, the printer company did not accept lower than 72dp. My flattened PSB file was 1.7 GB.
However, as I’ve said my 3D shape is an air balloon and not like the subject of the discussion here - a sphere. No mapping worked for me so I simply converted my nurbs to mesh and without mapping the texture fits perfectly well (of course I had to play until I found the right proportions of the texture).

Now I can’t split the mesh properly - always getting jagged edges. I run both:

ExtractNonManifoldMeshEdges
ExtractDuplicateMeshFaces

The problem also would be if I decide to keep just 1 segment (24 in total), than polar array it 24 times - I’m getting the same piece of texture and as I have not mapping method applied I can’t change / rotate the mapping for the rest of the segments.

Any idea how should I get mesh split doing better job?
thank you

Hi Alex,

Model in Nurbs first.
Split that up for your panels. Join these into one polysurface.
Mesh this polysurface to a reasonable density. “Reasonable” being dense enough to approximate the shape but no more.
Now apply UV mapping such as cylindrical or spherical and tweak the mapping widget a bit as appropriate. You don’t want surface mapping as this will not behave when you explode the mesh.
Apply your texture. You may need to do a bit of pre-distortion to get it to work nicely.
Now you can explode the polymesh and you’ll get your textured panels ready to flatten.

Regarding resolution. If your printer wants to shove a 1.7GB file through their RIP then I suppose that’s their problem :wink:
However you might want to discuss scaling with them.

Cheers, Steve

Hi Steve,

thanks for helping :slight_smile:

One strange thing appears. The curve you can see comes from the engineers and that is how my flatten texture should be shaped. Strangely my mesh seems twisted like it’s out of symmetry while I have spent long time for generating this beautiful mesh and everything is symmetrical. Any idea ?

Big thank you!

@Alex - Is that a “mesh” object or a NURBS surface? How did you flatten it?

@davidcockey this is a mesh flattened already. I followed the steps by @Maciej

using _Squish

This happens a lot with Squish if you have singularities (ie. the pointy tip of the gore panel)
Trim a bit off the gores and mesh that.
The other trick is to make the panels Degree 1 across the panel. After all they will be cut from flat fabric anyway

Steve

@Steve_Howden , I do something wrong. I trimmed a bit off the gores on the top but it does not get better. Maybe I should trim off much more?
Talking about _changeDegree to 1 totally deforms my nurbs segment into 3 flat areas. Is there something I can use to treat the mesh for getting better squish after?

Maybe my particular workflow caused this issue with Squish, which is:

  1. I work on 1 segment only which has 2 surfaces
  2. both surfaces go in GH turn to mesh and merge in single one (perfect quads)
  3. polar array of the mesh and Group (this allow to see the texture on the whole balloon). Doesn’t matter the tons of widges generated.
  4. squish

thanks for taking time! Apreciated
Cheers :slight_smile:

Hello,

the topic remains unsolved for me.
I now use Version 7 SR20, however when I _squish 1 segment (which mapping is still spherical after exploding the sphere) I got flatened version but the mapping is diferent (stil spherical thought). Any thoughts how to proceed? Thank you

Hi Alex - Yeah, I know - this does not work… the way out, I believe, is to Bake the surface to a high-ish resolution image, then Mesh the surface and Squish the mesh… The problem is the spherical mapping gets transferred to the flattened object where of course it no longer makes any sense - by ‘baking’ the texture you can sidestep the mapping completely.

-Pascal