Unroll surface with texture accurately


I’m attempting to unroll a surface with a gradient texture on it. The gradient is smooth and seamless when I unroll one part of the surface, but when I unroll another part, it’s as though the texture has been reprojected onto the unrolled surface. The successful one (see screenshot) was unrolled with “Keep Properties,” the other one not so–so although I have done the exact same procedure for both, I got different results! This is pretty confusing.

The texture mapping was applied to the object on the left of the screenshot as a closed solid. It was a planar mapping of a rhino gradient material. Then I unjoined edges around the desired box template, and unrolled each side (displayed on the right side of the screenshot) separately.

Thanks for any suggestions.

Update: problem not quite solved

I figured out that I can use the bake command to force the texture to be surface mapped rather than projected. However I wind up with a different version of the same problem. Now the first piece still unrolls correctly, but the second piece unrolls with the texture remapped to each individual surface. See image.

Am I using the bake command wrong somehow? It’s not like there are a lot of settings.


What happens if you run the UnrollsrfUV command? Does that keep the textures correct?


Then it unrolls without any texture, as a blank surface.


when i first tried it, i got a similar error which was caused by not creating a seperate material for the second object. Below attachement was done like this:

  • created the geometry from a solid cross
  • exploded the cross polysurface
  • while geometry was selected, i ran _RemoveFlippedNormals
  • joined surfaces to get upper part (A) and lower part (B)
  • used _UnjoinEdge four times on each part
  • created 2 new materials, one for each part using the gradient
  • set up the planar mapping from the top view, for each part seperately
  • used _Bake and saved two texturemaps (…A and …B), one for each part
  • used _UnrollSrf for each part with these settings:

_UnrollSrf _Explode=No _Labels=No _KeepProperties=Yes

this time it seemed to work. I guess the problem either happens because only a single material is used or because of the mapping not done individually. I am not sure if it makes a difference without removing flipped normals. Note that when you load the file below, you might have to re-assign the texture maps A and B.

Unroll_Textured.zip (70.5 KB)



This solves the issue perfectly! I didn’t know there was a command like _RemoveFlippedNormals, that seems to have been the culprit. Thanks!