Undesirable Unrollsrf Result


#1

G’day @pascal and McNeel,

Attached is an undesirable result from an unrollsrf, the circled corner is rounded on the unrolled surface. Shrinking doesn’t seem to work. It was created with the developable loft option.

Any other ideas?

regards,
Nick.
Rhino 5 - UnrollSrf Bug.3dm(250.5 KB)


(John Brock) #2

This is a classic case of why you should not turn off showing surface isocurves.
Your original polysurface is a mess. The nastiness of it is being masked because of your display settings.

Select the original polysurface and in Properties, check the options for making the isocurves Visible.
Yuck!
This polysurface will need to be cleaned up and simplified then it should unroll accurately.
Your input just exceeded the ability of the unroll tool to cope with it.

Try rebuilding the surfaces with a few points as possible to reduce the noise.
Then Unroll should work much better.


#3

oh yuck, you are right. will throw it back from where it came and admonish the newbs. thank you.


(John Brock) #4

Like voting in Chicago, newbs should be flogged early and often.
It’s for their own good…