Unable to place dimensions in some (but not all) layout views

I have a problem that first occurred in Rhino5, but is still a problem in Rhino6 to my surprise.

Some, but not all, layout views can not be dimensioned. It does not matter what the layer state is. Some layout views (I have quite a few) lose the ability to have dimensions added somewhere along the way. I have made a fiim to show the problem, because it is hard to describe. The layout in the film linked here


was actually working until recently. I had copied the layout view from a working one and reconfigured it, to replace the one labeled “dead”. I thought this was a solution, but apparently not. Now, for no reason that I can seem to repeat, whenever I place a dimension, it just vanishes. The dimensions (ordinate, linear, aligned) that were present at the last save are also vanished.

I am using a worksession, if that matters. The files involved are fairly large.

This problem is costing me are stopping me because I need to be able to dimension these layouts.

HELP

Hi Doug - can you, in a view where things fail, make a dimension and then run SelLast - what does the command line say?

-Pascal

I have done this
“1 ordinate dimension added to selection”

!?

Pascal, so going a bit further, I try also to isolate this dimension with first Hide and then
HideSwap.
SelAll
“1 ordinate dimension added to selection”
Zoom s
“Unable to zoom - no objects are selected.”

Hi - I’ve watched that video a few times but there’s not much to go on to try to reproduce this here.
If you delete all geometry, do the layouts still behave like that? If so, please post that file.

I tried this. I had to leave some things behind to allow the effect to be recreated. It likely has something to do with the clipping planes in use for the detail views.

DougDimensionBug.3dm (1.7 MB)

Thanks for that file!
Opening it here, I see that the current layer (DwgDims) is turned off in the 2 layouts that remain in that file.

This will make objects that are created on this layer in these layouts become invisible right after creation.
Turning on that layer in the layouts should solve this - let me know if it doesn’t.

And, FWIW, we have that issue on our list but it has dependencies that we won’t be able to address before RH7.

That appears to be the issue. I don’t think I ever used that part of the layer manager.

Apologies for the trivial question and thanks for checking it.

1 Like