Unable to open bitmap file 'Brazilian oak.rmtl' - unknown file type


I am trying to load materials from the materials library however when I do so all that happens is that the surfaces goes white and when I try to render it says the .rmtl file could not be found.

I’ve attached a screenshot, the object I am trying to apply the texture to is the table. I have had some success manually downloading the textures from the mcneel site and then linking them locally, but this takes a longggggg time to find the file.


Hi Callum,

Thanks for the report. I’m able to load the Brazilian Oak material here from the library and the texture is shown. The library textures are not downloaded by default due to the number of them but instead get downloaded when you first open a material. Are you connected to the internet through a company or school network maybe that might have a firewall? I’m wondering if this could be stopping the download of the texture map. Check the textures section of the material a little ways down from where you show in the screenshot. Is the texture not there or not found?

If you are on a network that is working to download the material textures, you can use the command DownloadLibraryTextures to grab them all at once in order to work offline or behind a firewall.

Also, how are you trying to open an Rmtl? Use the drop down for the material in the Properties panel > + symbol > Load from library or the same in the Materials inspector panel which can be displayed in the inspector panel section at the bottom in the right sidebar.


Thanks for your reply, the texture is just white when I click on it. I’ve tried to run the DownloadLibraryTextures command to download them all but I don’t think it did anything as I can’t find them on my laptop anywhere.

I wasn’t trying to specifically open the .rmtl file that was just the readout it gave me when i was trying to set the texture, as in seen the bottom left of the screenshot.

When I click render, I get a message box that says the image files are missing. From here I can get the URL to the file type it into the browser and then find the texture off your website, so i’m assuming if it loads that way then theres no firewall stopping me.

I’m trying to add textures to a whole house so downloading them manually just takes too long.


Also, I’m completely dumbfounded that rhino says the .rmtl file is unrecognized.

Unable to open bitmap file ‘Black and white doormat.rmtl’ - unknown file type
Unable to open bitmap file ‘Brazilian oak.rmtl’ - unknown file type

Are you connected to the internet through a company or school network maybe that might have a firewall? I think this is the issue at the moment. It would also explain why the DownloadLibraryTextures command didn’t do anything.

How are you trying to load and assign rmtl files? Are you clicking the + symbol in Properties > Materials or the Materials panel and choosing Load from Library?

Using the materials library and choosing load from library. I’m 100% sure i’m not sat behind a firewall stopping this as for my colleague sat next to me on the same wifi it works fine.

Okay thanks, is it just some materials or all that don’t load with textures and this error message? I am unable to reproduce this here so far in Rhino 6.17 for Mac. Can you also run the command SystemInfo please in Rhino 6 and paste the text back here? Maybe it will have some clues.

Rhino 6 SR17 2019-8-24 (Public Build, 6.17.19236.01022, Git hash:master @ 06b69c5cc21d880aa793a5a7cfd454a66f6213bb)
License type: Evaluation, build 2019-08-24
License details: Stand-Alone
Expires on: 2019-12-08

Apple Intel 64-bit macOS Version 10.13.6 (Build 17G8030) (Physical RAM: 8Gb)
Mac Model Identifier: MacBookPro14,1
Machine name: Callum’s MacBook Pro
Language: en-GB (MacOS default)

Intel® Iris™ Plus Graphics 640 (OpenGL ver:4.1 INTEL-10.36.25)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

So the file already had some textures in as it was originally created by someone else and I’ve added a few manually but other than that I’ve not been able to load any materials in. I’ve tried a load of different ones.

Thanks for you help with this!!

Thanks for the system info, I’m not sure why this isn’t working for you yet. Can you try another internet connection as a test please? Also, try in a new file too to rule out this being file specific.


I’ve tried on another internet connection and with a new file and it still won’t load.

Any further steps you suggest?


I was having this problem as well and it took a lot of figuring out - but I think I have finally solved it.

  1. Select the material in the library folder
  2. Open
  3. Import
  4. Assign to Objects.
    Seems that the order you do these things is important.
    It’s not an internet connection problem.

Just to follow up on that last post. You can have the part selected while you are importing the material - but it wont apply automatically. You have to drage the material to the selected part to apply.