DownloadLibraryTextures does not work

Hi everyone,

we tried to use the materials provided in the installation of Rhino 6. There are texture images missing which must either be accessed directly on the McNeel cloud or downloaded all at once via the command “DownloadLibraryTextures”

In our environment nothing works and i’m wondering why. Especially the return message of the command “DownloadLibraryTextures” says “Unpacked textures for 1301 render content files” but there are no files downloaded!?

Is there a possibility to download it manually?
Where will be the location of the files?
Any other hints regarding the textures of your materials?

Thanks

Hi -
It sounds like the download succeeded.
I’m not familiar with how that process works, but from the help file:

The DownloadLibraryTextures command runs through the entire list of materials in the material library and downloads all of the required bitmap files from the Rhino server to the local computer. After that, any material can be used from the library without being online.

To me, that sounds like the rmtl files in your %appdata%\McNeel\Rhinoceros\6.0\Localization\en-US\Render Content directory are updated with the required bitmaps.

How are you determining that nothing works?
Also, is it possible to temporarily turn off a possible firewall and test if things behave differently then?
-wim

Hi,

if have started the command “DownloadLibraryTextures” and then i created a sphere, imported the material “Anigre” from the material library and it looks like this:

Also the texture file Anigre_100_DP.jpg is not in the render content folder.

So i assume after the download of the textures this material should work, but it obviously does not have a texture image (or this kind of anigre is totally white :wink: )

Hi - I now tried the DownloadLibraryTextures command and that seems to work fine here. It places the downloaded texture files in the following folder:

%appdata%\McNeel\Rhinoceros\6.0\Localization\en-US\Render Content\Textures

If you are running Rhino in a different language than English, you will have to replace en-US with your localized path.

After downloading the textures, there should be approximately 700 files in that folder.
-wim

Hi,

sorry, no, there are only 73 texture images (see Screenshot) and the Anigre_100_DP.jpg is missing.

Did you look under de-DE?

Hi,
yes of course, also only 73 files. Sorry :neutral_face:

Hi -
Are you behind a firewall?
-wim

Hi
yes, behind firewall and proxy server with authentication. So i assume it will not work in my environment.
Is there any workaround, like to download it via a browser and to copy it to the right location?

Here’s another option since Rhino is blocked from accessing the internet,

  • Download this Zip http://files.mcneel.com/rhino/6.0/textures/Rhino_6_textures.zip
  • Extract the contents
  • Move the textures here or to another language folder if needed. Type “%AppData%” if you don’t see it… then go to C:\Users[YOUR USER NAME]\AppData\Roaming\McNeel\Rhinoceros\6.0\Localization\en-US\Render Content\Textures
  • Restart Rhino 6

Any luck?

Hi -
Apart from the link that Brian provided, it looks like Rhino should be able to self-check the download process when running DownloadLibraryTextures. I’ve created RH-59310 for a developer to see if anything can be done about that.
-wim

Hi @BrianJ ,
yes that solves my problem.

Thank you