Unable to get LinkedViews and move objects about in Layout mode

Hi,
V5
Layout command, before running it I had my viewports linked so the grid was the same size in all 3 ortho views.
So in the normal views (pre layout) if I move an object to centre of ‘top’ view, it aligns with it in front view and end view aligns with front view. So it looks like it would on a 3 view traditional drawing, Internationally expected and accepted that 3 views projection lines all go to where they should go to.

If I use Layout view they cease to do this. I need all three views as 1:1, ALIGNED as is correct practice and goes without saying.

Also having done so for detail, and locked the scale, I cannot even move the object now, let alone get them to align.

The whole advantage of layout is to create a traditional 3 view drawing, with display colours, shades etc.

How do I get them to align up as in normal view or even move the object into view when scale is locked ?

A vimeo vid shows an L being drawn then move command to snap objects to it, (need group them all first) I try that and it wont snap to the box I draw when detail views are deactivated.

Steve

Steve -

V5:
image

You are not locking the scale. You are locking the detail.
When it’s locked, it’s not going to move.

To align 1:1 details:

  • unlock all
  • activate a detail
  • run ZEA (Zoom Extents All)
  • deactivate the detail
  • select each parallel detail in turn (*) and set the scale to 1:1
    image

(*) In Rhino 7, you can select all parallel details at once and set the scale for all

Note that you can also move locked details and snap to geometry that they show. You can line up detail this way as well.
-wim

Hi,
V5,
http://help.mcneel.com/en/rhino/5/level1/13-printing-and-layouts

They had us set scale for each layout viewport and lock it so I followed that.
extract tutorial McNeel:-

  1. Select the Top detail. Do not double-click to activate.
  2. In the Properties panel, click the Detail page
  3. In the Scale area, set 1.0mm on layout equal to 1mm in model.The scale is now set to 1=1.If you set 1mm in the layout equal to 2mm in the model detail, it is half size or 1=2.If you set 1mm in the layout equal to 10mm in the model detail, the scale is 1=10.
  4. · Make detail active by double clicking it and pan geometry to center in viewport. Deactivate detail by double clicking.
  5. · Select detail and in the Properties panel, click the Detail page and then click Locked .Details that are locked prevent zooming or panning, making it easy to keep them from changing scale.

so what you are saying is in order to pan about, dont lock it.

I have created a test file, see attached, what I need is to do a layout of the dome thing and associated bits at front end.
I create a new layout, one can either select top view normal mode then go View menu>Layout>New Layout or as I prefer as its quicker, click the + tab found next to the four normal views lower left.
name the layout view ‘Dome and Rod’

I select the border of the top pane and go properties and make it 1 and 1 so its actual scale.


repeat for the other three ortho layout views.
I make them shaded by double click and choose shaded from View menu top screen.
I shove hand them to get them roughly in the panes, I cant see a Rhino grid when the pane isn’t active.
I check I haven’t messed up the scales by inadvertently using scrollwheel,
I did have linked viewports ‘on’ before running layout command,
They havent aligned, I cant see the grid to be sure but they dont look good.

Also now that I am in shaded mode I see what I thought was the end view was in fact the other end of my box, .
How do I change that pane to ‘LEFT’ view as if I go to view menu and choose Left VIEW it becomes a non layout type of view and doesnt go grey when double clicked.
The dimensions have gone huge in the overview which I also need to do as a layout. They dont look like that in normal mode, and I have placed hundreds into the model over 4 months during build, as you do, and they are ready for plan making.

So I have the wrong view of that end, and how do actually get the viewports to align as in normal engineering drawings, as said I cant see the grid. I try drawing an L line as per a video I saw, I zoom in to select the item that should be on the line, it wont snap to the line, and of course even if it had, setting it back to 1:1 loses that positioning. I also tried it with the ship model the tutorial uses., aligned despite no snap to a line visually, then set the scale back to 1mm=10m and the ship moved away from the line through its centre !

I try for the delete geometry in perspective view to create an empty pane for the logo and text again and all vanish.

here is my test file:-
Test objects Layout command_v3.3dm (4.6 MB)

Steve

1 Like