Unable to create or edit materials in Rhino

Hi all,

Currently I have a problem with creating new material or editing existing material on material editors.
Even if it is a simple color material it doesn’t save up so now I can only use the materials that’s been saved previously.

Can anyone know what’s the caused to this problem?
My colleague seems to have the same issues.

Help please!

Thank you,

For starters, which version of Rhino are you using?
Additionally, are you using a 3rd party render plug-in?


We’re using Rhinoceros 5.5.3 for Mac and we don’t use any other plug-ins.
And it happens with my colleague since the first time she purchased the license.
Unable to create materials, even if it’s just a simple color coded material without importing any images we still can’t save and use the material.

Because usually after we create the material there would be a pop up message saying “would you like to save …”, but now it doesn’t show anymore.

Hi Chichi-

Can you provide us with detailed steps to reproduce what you are seeing? Sometimes the devil is in the details.

It might also be helpful to give us some more System Information. Navigate to Rhinoceros > About Rhinoceros > More Info > Copy to clipboard and please paste the results back in here.


Hi Dan,

  1. MaterialEditor
  2. Add Materials under Library - Custom Materials
  3. Edit Library Material
  4. Change the material color
  5. Close the pop up window.

Then nothing change and no pop up messaged asking me if I wanna save the material.

System Information:

Software information

Software versions
Rhinoceros version: 5.5.3 (5F88)
Rhinoceros path: /Applications/Rhinoceros.app
IronPython version: not installed
Language: en-ID (MacOS default)
macOS version: Version 10.14.1 (Build 18B75)


Third party kernel extensions

Hardware information

Computer hardware
Hardware model: MacBookPro14,3
Processor: Intel Core i7-7820HQ CPU @ 2.90GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Radeon Pro 560 4096 MB
Memory: 4096 MB
Screen size: 1920 x 1200
Displays: Color LCD (295dpi 2x)

USB devices
Apple Inc.: iBridge

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-2.2.8
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

Thank you,

Thank you @chichi.tjandra for the detailed steps. That is exactly what I needed.

Ugh. That is a bug. This appears to be a regression in the 5.5 update to Rhino 5 for Mac. (This bug is not present in version 5.4.2). This needs further investigation.

There is a work-around…

  1. Drag your custom material from the Library panel on the left-hand side, into the Model Materials panel on the right-hand side.
  2. Select and edit your custom material in the material editor panel below.
  3. When you are done, you can drag this material back to the Library on the left and your customizations should stick.

Sorry about this bug and thank you for reporting it. Logged in MR-3265.

Ah, that way works! That would be helpful for the time being.

Thank you for your help!

Hope the bugs will be fixed soon

This issue is fixed in the latest update to Rhino 5 for Mac. Thanks again for reporting this and for your patience.