Unable to close brep with cap holes

Hi all,
I’m working on a 3D street map. In order to be able to print the map on a small 3D printer, I want to cut the map in a number of smaller tiles that fit the size of the build platform of my 3D printer.
To achieve this I’m using the “Split Brep Multiple” component and afterwards I want to close the resulting breps with the “Cap Holes Ex” component.

question cap holes.gh (736.6 KB)

This worked fine on other 3D maps I made in the past, but for some reason Cap holes is not able to close the breps in the example file attached to this post.


Have you tried lower Absolute tolerance value in DocumentProperties?

No I didn’t try this. In fact this question is related to another question I posted a while ago. Back then I had some issues when using solid union, and this problem was caused by the fact that i lowered the absolute tolerance. https://discourse.mcneel.com/t/not-able-to-join-large-amount-of-breps-with-solid-union/99754/4?u=toms

What @Joseph_Oster suggested seems to work here too.

By Lower I meant smaller(tighter) tolerance.