Clipping plane display problem

Hello - I’m having a problem with the clipping plane and I’m betting it’s user error but I haven’t been able to solve it. I’m using a simple file - 1 MB in size. When I enable the clipping plane in any viewport, the drawing disappears. I haven’t used the CP in a while so at first I figured I was putting it in the wrong place and the drawing was being clipped, but when I move the clipping plane around, the drawing does not reappear. Disable the CP and the drawing reappears. This is happening in two different files and all views. I’m using Rhino 6. Suggestions appreciated.

Rhino 6 SR12 2019-1-29 (Rhino 6, 6.12.19029.6381, Git hash:master @ ae9d7fba5fda0b43002dc44a34e059a9a382db04)
License type: Educational, build 2019-01-29
License details: Cloud Zoo. In use by: Sarah Kayser ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-9VDD799

Non-hybrid graphics.

Secondary graphics devices.
Intel® HD Graphics P530 (Intel) Memory: 1GB, Driver date: 2-28-2018 (M-D-Y).
NVIDIA Quadro M1000M (NVidia) Memory: 2GB, Driver date: 3-16-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-16-2018
Driver Version: 23.21.13.9125
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\export_AI.rhp “Adobe Illustrator Export”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\sarah\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.10.11.800\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi - I would try updating the drivers for your GPUs - both the Intel and the NVIDIA ones. The ones you have installed are getting old.
Please let us know how that goes!

Thank you for the suggestion. I updated both drivers but the issue is still occurring. Any other ideas?

Hi - Could you post a simple file in which you are experiencing this issue?

Another update… I went to a completely different (older) file and the clipping plane works normally. The two files that are having the issue are both recent, similar files. I added another object to the file (a section cut), and the clipping plane behaves almost normally with that portion of the drawing. If the clipping plane is drawn to include the section cut, it clips properly even though the main part of the drawing still disappears as soon as the CP is enabled. However it also clips the section cut drawing even when the CP box is NOT drawn around it - just next to it. Very odd. I will keep trying to figure this out, but if someone has a suggestion, please let me know.

Attaching the file. Thank you! New Mexico Topo.3dm (1.1 MB)

Hi - your file has 1 clipping plane that is only enabled in the perspective view. When I open your file, this is what I see:

Could you post a screen-shot of your perspective view after you open that file again?

With clipping plane enabled:

With clipping plane disabled:

Thanks!
Does it make a difference if you uncheck the Rhino Options > View > OpenGL > GPU Tessellation option?

Also, could you rerun the SystemInfo command and post the updated information?

Hi Wim,

The GPU Tessellation box was already unchecked. Screenshot below in case there is anything useful there. Also I’ve pasted my SystemInfo below.

SystemInfo:

Rhino 6 SR12 2019-1-29 (Rhino 6, 6.12.19029.6381, Git hash:master @ ae9d7fba5fda0b43002dc44a34e059a9a382db04)

License type: Educational, build 2019-01-29

License details: Cloud Zoo. In use by: Sarah Kayser ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Machine name: DESKTOP-9VDD799

Non-hybrid graphics.

Secondary graphics devices.

Intel® HD Graphics P530 (Intel) Memory: 1GB, Driver date: 2-28-2018 (M-D-Y).

NVIDIA Quadro M1000M (NVidia) Memory: 2GB, Driver date: 3-16-2018 (M-D-Y).

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: 4x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation

Render version: 4.6

Shading Language: 4.60 NVIDIA

Driver Date: 3-16-2018

Driver Version: 23.21.13.9125

Maximum Texture size: 16384 x 16384

Z-Buffer depth: 24 bits

Maximum Viewport size: 16384 x 16384

Total Video Memory: 2 GB

Rhino plugins

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.12.19029.6381

C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”

C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”

C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”

C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”

C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.12.19029.6381

C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Users\sarah\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.10.11.800\PanelingTools.rhp “PanelingTools”

C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”

C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.12.19029.6381

C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.12.19029.6381

C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi - do you remember why that checkbox was unchecked? Please try to check it again.

Also:

Those are the same dates on those drivers. There should be more recent ones.

When I rechecked the PU Tessellation box the issue was resolved. Thank you for your help!

Hello - do you recall why you had unchecked that box? By default it is checked. Was there another display issue that this helped with?

-Pascal

I believe I unchecked that box when I had another display issue maybe 6 months ago and I found that on a forum as a possible fix. I don’t think it actually solved the issue - sorry I don’t really recall the details. It might have been another clipping plane display problem or it might have been with make-2D. Pretty sure I gave up on that one as the file was pretty complicated so I thought it might have been too much for my laptop.

HI, am Josh and am having the same problem with the clipping plane. My GPU Tessellation was already checked and when I unchecked it, it did not seem to resolve the issue. Please help. I have also tried to uninstall and reinstall rhino and this has not fixed it either.

Hi Josh - please run the Rhino SystemInfo command and post the result here.
-wim