Display Modes (pen & artistic) Showing Text & Clipping Planes

Some display modes are still displaying text and clipping planes after disabling them, any ideas ?? V5 Windows 10

The text is probably in Blocks.

hi, thanks for chipping in, no none of the text, annotations or clippings are in blocks, they are failing to turn off in most display modes :thinking::pensive:

Please post a file…

Hi Wim, file attached, cheers Text Showing.3dm (18.7 MB)

I see that here as well. Some of the text actually disappears from the view when it is unchecked in the display properties while other text remains visible. I haven’t found out why.

Thing is…
this seems to work fine with your file in Rhino 6.

yeh using V5 here, it used to work just fine, I try and put all my text, clipping planes, dimensions on their own layers, so I can workaround this, its just a pain when it used to work fine, I use layout pages a lot too, and present different perspectives in Pen Mode, so a double pain :expressionless: