Turn off Grid Lines and Axes so they stay off?

I turn off grid lines, grid axes and world axes icon (and select all views) to make screen shots - but they keep coming back. Quite a few clicks to go to settings and then three clicks for each to turn them off.
Would be nice to silence them all in one or two clicks. Possible?

HI @tgra,
You could create a view mode that has grid deactivated and apply that mode whenever you want to create your presentation.
1 Go to preferences> display modes
2 Select your current mode, and duplicate it
3 Go to Grid tab, and under Grid Setting > Grid Usage, select Use Mode Specific Settings. Now you will have the option to deactivate Show Grid, Show Axis, Show World Axis

From now on, whenever you need it, you just have to change your view mode.

Cool Idea Jespizua, thanks for that suggestion!

Glad it worked out for you!

Note that these settings are document settings, not global ones, so you can also create templates that don’t have grid/gridlines showing if that’s what you want by default. It’s also easy to use a macro like the following with an alias or hotkey that toggles gridlines/grid axes:

This one’s for Windows

_-DocumentProperties
_Grid _ApplyTo=AllViewports
_ShowGrid _ShowGridAxes _EnterEnd

And, since DocumentProperties is named Settings in MacRhino, I think this should work on Mac (not tested)

_-Settings
_Grid _ApplyTo=AllViewports
_ShowGrid _ShowGridAxes _EnterEnd

Thanks Helvetosaur, I work with the axes and grid lines turned on most of the time but wish to hide them briefly while I take screenshots, then turn them back on again - it’s not a big deal - just a bit annoying that they reappear without changing the settings.

When do they reappear if you haven’t called them back specifically?

I can’t say specifically what brings them back. It’s been an issue going back the Rhino for Mac WIP and then V5 and now 6. If I can track down any specific command that makes them appear I will let you know.

OK, because that shouldn’t happen…

I use aliases for that - works fast without another display mode:


GR | Grid h ENTER

(for active view)


GRR | Grid p h ENTER

(for all four views)

You could use ViewCaptureToFile for your screenshots, which gives you control over grid display, etc .from within the command, plus a whole lot more! I sound like an ad…

To try to isolate the problem I purged history, rebooted Rhino, and turned off the grids. After about 6 or seven minutes of working and about 40 or so history incidents the grids had reappeared.
I did this twice with a similar result each time. I have copied and pasted the history into a text document but there are 38 commands so don’t know how you would isolate problem.

The problem appears to be with packing support files which are constantly appearing in my history. I found a post how to turn these off in windows but not for Mac. Any clues?Screen Shot 2020-02-09 at 10.21.46