Trying to Diagnose New Bongo Crash Issues

I’m having new issues with Bongo crashing, and I can’t seem to pin down the cause. Previously, I was having a RAM memory leak issue due to bug with the Intel Denoiser. I disabled the denoiser and was able to Render an animation with 900 frames without crashing. In that case, I was animating a worksession file. I estimated that the total size of the files within it was 877 MB.

Another fix I did was to change the mesh settings to “Jagged and Faster” which really speeds up the rendering, without really costing any quality.

Now, I am trying to render another model animation with about 700 frames. This is another worksession with an estimated size of all files being only 330 MB. I removed an emissive surface which was really causing the renderer a lot of problems, and the frames seemed to render really fast after that. However, it crashed after 394 frames. And then I tried rendering the animation again and it crashed after only 6 frames. I’m not seeing a memory leak. I’m not sure what’s going on here.

Another possible cause to look at. My hardware is as follows:

Video Card: NVIDIA Quadro K2000, 2GB

From what I see from other Bongo users. It looks like 32 GB to 64 GB RAM seems to be standard. But I saw that people’s video memory was in the 6 GB to 16 GB range. So I might be low there. Could this be part of the problem?

I guess I’m confused because things seemed to be working fine earlier and now they aren’t.

Bongo 2 Version 2/12/2019
Rhino Version 7.4.21054.9561 (64 bit)



Would you be able to share the crashing model with us?
If you get the Rhino crash dialog up after it goes down, please send it in and tell us the details you used so we can look it up in the system.

Hi Marika,
I just had another crash with the same worksession model and animation set. It crashed after 32 frames out of a total 400 frames to be rendered. I had it send the error report. The email I used was and I included a short description of it crashing after 32 or so frames. This is a worksession file. Do you want me to send all the individual files in a zip? You may have to re-attach them to the worksession.


We found the error report but I didn’t give us enough information to figure what went wrong. The model would definitely be helpful. You can send it to us confidentially here.

Hi Josh,
Sorry for the delay on this. I thought it was working better again, but now it’s not. I tried to upload the files, but I think the zip file is too big for your uploading utility. It’s 245 MB. Another thought I had is that I have combination of Rhino 6 and Rhino 7 files in the worksession. I wonder if that might be part of the problem.

I just did a render and it crashed after 7 frames on a model that was working fine earlier. There must be some new issue, but I’m not sure what’s causing it. I don’t think uploading the model to your site. is going to work because it’s too big. Is there any way I can dropbox it to you guys?