Trouble with open polysurface for 3D printing

Hello, I am trying to create a solid for 3D printing. The screenshot shows where I’m currently at.The top piece is a closed polysurface, but the ‘tube’ part of it is open - the edges of the curves I used to trim the surface all appear open.

Steps I took:

1: imported curve pattern from illustrator (for cutouts) - they were closed curves at this point
2: using a rectangle, I trimmed the pattern to be the size of the surface I would project it on.
3: created a surface under the pattern, and used the pattern to trim surface
4: projected cut surface onto tube surface, then deleted tube surface (once cut surface was in position/shape).
5: I then made the top piece in a similar way, but it appears to be closed.

I want to join both surfaces (as you can see, the cutouts match up) and be able to 3D print it.
I already achieved this with a portion of the piece, working in the same way.

I am relatively new to Rhino and I’m sure there’s something I’m missing that’s messing me up. I don’t understand how to cut through a surface (split or trim) and not have an open surface after that?

I would like to know if there’s a way I can fix the design at this point, or if I have to go back and start over. In which case, how should I go about making the design?! What’s the correct approach?

Here’s an image of the pattern I used (I modified the proportion), and the surface I cut into before projecting it


And the part that is a closed polysurface:

Here’s the STL of the portion I 3D printed successfully:

Split or trim will leave open edges - they are curve/surface editing commands, not designed to close volume objects.

The classic ways to trim/split things “volumetrically” keeping objects closed are:

  1. create a surface (via Extrude or other surface command) and then use BooleanSplit command.
  2. Use the command Wirecut with a cutting curve

I don’t quite understand how yo got your pattern onto the tube, you say “project” but project doesn’t work like that, so I imagine it was either Flow or ApplyUV. It doesn’t look like the tube has thickness - a simple surface doesn’t have any. To create the thickness, you might try using Offsetsrf to the inside with the solid option checked…

The best thing would be to post your file here, it’s hard to tell what’s really happening from an image.

–Mitch

Sorry, I meant flow, not project. I’ll post the file<img

bowl_post-2.3dm (2.9 MB)

OK, so there are several problems with your file. Let’s take them one-by-one.

  1. Your outer (tube surface is OK for the moment, but it’s just a surface, no thickness (yet). Let’s leave that aside for the moment.

  2. Your “top” surface is actually a closed polysurface, but it’s composed of 3 surfaces, two of which are almost identical. I don’t know how it got that way, but this needs to be fixed first. Explode it to turn it back into 3 surfaces, delete one of the near-duplicates (I suggest the one with the hole in the center) and save the little dimple surface for later.

  3. The edges of your tube surface and bottom cap don’t meet. They are off by 0.011 inch. The flat cap surface is actually on the Z0 plane, so move the tube surface up so that the bottom edge is also on the Z0 plane. The centering of one piece on the other is also off by 0.002 inches, you should correct this as well.

  4. Bring back your dimple surface and trim the bottom cap with it, then join all 3 surfaces.

  5. You can now try OffsetSrf with the solid option - . This is a complex shape to offset, but here it seems to work OK either to the inside or outside with thin sections (I tried 0.05), I don’t know what thickness you need. Outside with corner=round works for thicker sections. The dimple surface will have a problem offsetting though, it will leave a naked edge at the pole. An alternative is to either do the above without adding the dimple before the offset, and add it back in later, or fix (remake) the dimple making the profile tangent to the Z0 plane at both the bottom and the tip (which is what I did).

bowl_post-msh.zip (2.4 MB)

HTH, --Mitch

That’s great Mitch, thanks!! I’ll let you know how it goes in a couple days - 3D printing the tube part for now, which I finally got working.