Trouble Keeping a tight surface with Patch


#1

Hello everyone,

I have a network of curves with a boundary. I can’t use the networksrf command to generate the surface since I have a boundary curve that intersects the rest of the curves…So when I use the patch command, (sample point 10, UV spans 10) I get a surface that isn’t tight enough to my boundary line.

I eventually want to join my generated surface (red) with the existing surface (pink). Can anyone give me some insight how to better achieve a tighter surface?

I’ve attached the model below.

Thanks.

PATCH.3dm (334.3 KB)


(Pascal Golay) #2

Hi Mikael - I’d make sure the curves intersect nicely and set the patch to use a denser set of spans. Then, MatchSrf the pink edge to the Patch edge for Position.

-Pascal


(David Cockey) #3

Two more suggestions.

Make sure you are using a small enough “Sample point spacing” in Patch. Patch fits to the sample points it generates along the curves, not the curves themselves. Or you can use Divide on the curves to create your own set of points. Also, since the largest deviation is at one of the corners you might create temporary points at the corners and include this in the input to Patch.

Experiment with the “Stiffness” setting in Patch. Smaller stiffness values can improve how close the Patch result conforms to the input curves and points. Too small a stiffness value can lead to waviness in the surface, particularly with large number of spans.


#4

Pascal/David

Thank’s for the suggestions. I generated points for each the curves and then a polyline through the points…so my network of curves had clean intersection points. I also made sure to add points to the corners. The patch command eventually gave me a nice surface…but it still didn’t join with the other piece…even though it shared the same boundary curve. So I tried the matchsrf command and played around with the refine settings and I was able to eventually match the surfaces by position. That did the trick.

Thanks for your help.