Trouble installing Brazil


#1

I have Rhino 5 (64-bit) installed. I demo’d Brazil and decided to buy it. I’m having trouble installing the copy which I purchased.

Part of this might be due to the fact I kind of gummed up the installation. Basically, the sequence of events was as follows:

  • install Brazil from DVD
  • test and get message telling me demo is expired. Feel like a goof for forgetting to uninstall demo.
  • uninstall demo
  • restart
  • test: no renderer other than Rhino render appearing
  • check and see that there doesn’t seem to be a 64-bit version of Brazil installed, only 32-bit
  • install 64-bit Brazil
  • restart
  • test and see Brazil appearing in list of renderers
  • attempt to select Brazil as current renderer and get the following message:

Plug-in name or ID ( Rhinoceros ): 66d400a8-0d44-4511-a9d6-613a4b6e0371
Unable to load default render plug-in.
Unable to make “Brazil 2.0 for Rhino (64-bit)” the current render plug-in

Wondering if anyone could suggest a way to get this working aside from just uninstalling and then reinstalling everything.

Many thanks!


(Brian James) #2

Hi Josh,

For future reference you can also email tech@mcneel.com to get help with anything like this. The forum is fine too of course but it might take longer to get a response.

Not being able to load the default render plugin in Rhino sounds like your Rhino 5 install needs to be repaired. Can you make sure you are using the latest service release of Rhino 5 from here? http://www.rhino3d.com/download/rhino/5.0/sr

If so already, try running the installer for the Rhino SR again and choosing “Repair”. I would then launch Rhino 5 x64 and check in Options>Plugins to see if Brazil is present in the list and loaded. If not, you may just need to manually load it from “C:\Program Files\Brazil 2.0 for Rhino (64-bit)” … it’s the rhp file.

It would also be a good idea to update to the latest Brazil service release too which is here http://www.rhino3d.com/download/Brazil/2.0/sr


#3

I updated Rhino and that didn’t fix the problem, but after I then updated
Brazil everything worked as expected.

Many thanks!