Trim command doesn't work properly anymore

Hi there,

I am following a lesson in training level 1- Rhino documentations, I have been stuck at some issue . Trim command doesn’t work as it used to be. it doesn’t trim anymore, don’t know if I mess with any settings that affectted Trim command or not.

For the lesson, as shown in the picture, I should select all surfaces, then do Trim command, and pick the outer edge of each surface, so it turns into something like this

When I pick the outer age of the behind surface, it deletes allof it, not the part intersecting the middle vertical surface.

I have been experiencing this for some days now, I just ignore this issue and use Split command which does the job, but thought to stop and ask so I can fix it.


Hello - please post a file with the surfaces.


Here is the file Extrude.3dm (186.7 KB)

Btw I duplicate the three surfaces and applied Trim command so you can see how Trim does the job wrongly.

Hello - here is what I get:



Yeah exactly this what should happen, but doesn’t work like this with me, should I reinstall the software?

It was working fine days ago, something wrong happen I don’t know what is it a a beginner.

What software you used to record so I can show you what is going on with me?

Or is there a way to reset some stuff in Rhino that relates to its commands.

Hello -

Please run the SystemInfo command in Rhino and copy/paste the results here.


@pascal Here it is

Rhino 7 SR5 2021-2-22 (Rhino 7, 7.5.21053.09001, Git hash:master @ bfa025d771a5586748502ab53ab7ad9214e81b4a)
License type: Corporate, build 2021-02-22
License details: Stand-Alone

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [98% battery remaining]

Standard graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 4000 (Intel) Memory: 2GB, Driver date: 8-6-2020 (M-D-Y). OpenGL Ver: 4.0.0 - Build
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build
Driver Date: 8-6-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2112 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.5.21053.9001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.5.21053.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.5.21053.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.5.21053.9001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.5.21053.9001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello - this appears to be a cracked version of Rhino and unlikely to work well.


Oh I see, I thought about this part but thought to ask to make sure. 90 days for learning doesn’t fit me now, hope I work on commercial version once I get job in some company.

Thanks @pascal, I will continue with Split command instead.