Trim command behaving strangely in Rhino 8

I am using Rhino 8 SR6. The trim command is not working as expected (this has happened time and time again since switching to Rhino 8)

Exploding the curves does not fix the problem, nor does toggling “apparent intersection”.

I can get it to work correctly if I copy the lines into a fresh rhino file, but I am tired of doing this and I would love it if the bug was addressed.

System info:

Rhino 8 SR6 2024-3-19 (Rhino 8, 8.6.24079.11001, Git hash:master @ 0d13b06881495403bd28e1cee93f8c8ea0baec7c)
License type: Commercial, build 2024-03-19
License details: Stand-Alone

Windows 11 (10.0.22000 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 10-18-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.70
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0
- Secondary monitor attached to adapter port 1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-18-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24079.11001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24079.11001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24079.11001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24079.11001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.6.24079.11001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24079.11001
C:\Program Files\Rhino 8\Plug-ins\export_PDF.rhp “PDF Export” 8.6.24079.11001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24079.11001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Hi Ben - please post a file with those curves.


trim bug (99.0 KB)

Here you go, I isolated the curves and saved them in this file. I figured out that part of the problem was that the curves were non-planar. BUT the apparent intersections option should work around that, and it is not

Trim works properly for me in your example file using (8.6.24086.11001, 2024-03-26).

Pascal may have an idea.

A stab in the dark would be to update the video driver to the latest.

Hi Ben - does the file you posted fail in the same way? I see in your clip that the camera location is different from that in the file you posted - should not matter but I notice it… might be a clue.


When I re-open the file, the bug is gone. So this one might be really tough to troubleshoot. Could also be unique to my machine. I mainly wanted to get get it out there in case others have been having the same issue.

Hi Ben - was this a unique occurence, or does it happen ‘sometimes’?


It happens several times throughout the week. Usually I try:

-exploding the curves
-projecting the curves to the c-plane
-toggling the “apparent intersection” option

And typically some combination of that will get the job done. But I did not run into this until the switch to Rhino 8.

The strangest thing is that sometimes the bug goes away when I turn OFF apparent intersections

Same issue as Ben’s using the trim command in Rhino 8. Also, booleans doesn’t work as expected. Latest video driver installed.

Hi Samuel -

If you have a 3dm file and specific steps to reproduce this / these issue(s), please provide those.