Topological mesh walking_Error while using exoskeleton and fattener

Hello ,
Greetings to all,
This forum has been a huge help to me.The amount of knowledge I have
received in the 10 days of joining is just commendable.I would like to thank everybody for their inputs.

I have been trying to figure out self structuring systems by studying steiner tree since long.Finally after having achieved it I need to maximize global double curvature to increase structural performance (as demonstrated through the work of the German Architect and Engineer Frei Otto) using the branches acting as spine with mesh around them.

I tried using exoskeleton and mesh fattener, they are giving me errors
I am attaching herewith the gh definition and references of what I ought to achieve.

What in cases where I need different radius’ at different places along the line segments.
The moment I change the count I get an error.There is some relation between no. of points in space, and the inputs of these components which I am not able to understand.


9d67606ad56a4e2fdce917679b3829ae ![64b50d17f124627af4208abfbc8c7610|564x420]

Steiner_Mesh (20.1 KB)

Thank you so much for your time in advance.


1 Like

Steiner_Mesh (28.5 KB)

Here’s a version with some fixes - mainly just extracting the right data path and cleaning up the topology with a bigger tolerance before thickening.

1 Like

Hi, I was trying something like this with a similar method of using voronoi edges and running it through exoskeleton. However, I ran into the same problem as the image above:

Op’s result and mine (L and R)

My original sequence

Copying from the BANG! components from the solution
Briefly, my approach (above) was to create a voronoi to extract its edge curves and trim off with a slightly smaller box so that I will not get the overall box’s edges. Then I use Kangaroo’s dupLn to remove lines that are within 10mm tolerance and Tologizer to join lines that are within 3mm tolerance. From there, I fed it into Exoskeleton but I got the output above. I saw the solution worked well with OP’s issue, but when I tried copying the parts from the solution (the BANG! component onwards), I got the same result. Could someone explain to me the solution or is it that my data is not sorted in the right structure? Sorry if this is a simple question, I really do not understand how to resolve this ‘entangled’ mesh issue. The exoskeleton sequence I did seems to only work in very specific situations. If I tweak the exoskeleton numbers or the original voronoi’s number of cells, the mesh ‘twists’ like this and I have been restarting my grasshopper and Rhino but it does not work also. Could anyone help me understand my mistake? Thank you very much!