Lock docked windows not working

I have a couple tool bars that are docked to both sides of my view port (circled in red). I was wondering is if anyone else has the same issue as me, when I check the lock docked windows option the next day I come into work and open rhino all my docked windows are no longer locked and have moved around and sometimes collapse. Is there any fix to this problem, its really annoying to rearrange them every day.

Hi Tommy - please try:

  • Close all but one instnace of Rhino.
  • Restore, i.e. not maximized, the main Rhino window.
  • By hand, resize until it is almost maximized.
  • Arrange the toolbars.
  • Close Rhino.

Does it behave any better after that?


No unfortunately it did not work.

This is the before picture after doing all the steps you provided.

This is after ive closed rhino and opened it back up, as you can see all my toolbars stay on the right side of the viewport I placed them in but they have rearranged their placement. Any thoughts? Ive tried it with checking and unchecking the lock docked windows. Could it have something to do with other users at work pulling a license for their computers, since they are all having the same issue.

Hi Tommy - ok… this is a known ‘weakness’ … the next thing to try is to consolidate toolbar files - if you have multiple toolbar files (.rui) open in Options > Toolbars page, let’s see if blobbing them all into one rui helps.

In Options > Toolbar, save the default under a new name, if you have not done that already -

Then with that toolbar file selected, Import toobars from the other RUI files:

Then Save your custom named RUI with all the imports. (Also save to a backup location or otherwise back it up) Then close all of the other RUI files that are open, since you now have all their toolbars in your custom.


Does that behave any better?