Toolbar page gone missing


#1

Hello, I am experiencing some strange problems in rhino 5. My toolbar page has gone missing. I reinstalled rhino a couple of times as i uninstalled it, deleted all McNeel and Rhino folders:
C:\ProgramData\McNeel
C:\Users\Your user\AppData\Local\McNeel
C:\Users\Your userAppData\Roaming\McNeel
C:\Program Files (x86)\McNeelUpdate
C:\Program Files\Rhinoceros 5 (64-bit)
C:\Program Files\Rhinoceros 5.
My Rhino crashes when right-clicking on any toolbar.
Ill be really thankful for helping me because i have no ideas and formating my HDD is not really a solution.

Velin D


#2

Hi Velin,

This happens occasionally, and if you google, you will see some of the solutions:

Go to Tools > Toolbar Layout, and choose File > Open, and choose “default.tb”. If you can’t find it, try searching your hardrive. It has to be be somewhere.


#3

Its the whole toolbar page, not the toolbar. When i enter the ‘options’, the toolbar page you refer to is not showing at all!.


#4

Not sure what seems to cause the problem.
Better wait for the mcneel folks to answer this.


(Pascal Golay) #5

Hi Velin- please look in Options > Plug-ins page for ‘Rhino Toolbars and Menus’. Does it show up at all? If so it is probably not enabled (Check box) so enable it and then right click on it and choose ‘Load plug-in’ and see how that goes.
If the plug-in is not there at all, click on Install, and find

C:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins\Toolbars\Toolbars.rhp

Does that load and work OK? It should show you the Toolbars page once loaded.

-Pascal


#6

Its already enabled and loaded. Thanks for the suggestion. Still doesnt show up.


#7

This is a long shot, but if the plug-in is present are any of the toolbars checked


#8

Hi Velsky, did you try ‘ToolbarReset’.

@brian I have just done a re-install as i was having some selection issues, and when starting up again, the toolbars were missing although the toolbars plug-in appeared in the list as loaded and enabled.
The screenshot shows that the UI folder was missing from the browser when I tried to open the toolbars in Rhino Options. I had also deleted the McNeel folders mentioned at the top of this thread, to get a clean re-install.

ToolbarReset with a restart fixed the problem here.


#9

it didnt happen for me. tried it several times.
Thank you anyway


(Pascal Golay) #10

@JohnM, do you have an idea? The plug-in is apparently enabled & loaded but there is no Toolbars page in Options.

thanks,
-Pascal