Toolbar missing (Rhino 5, 64-bit)


I’ve run into a problem with Rhino 5. While I had Rhino / Grasshopper running, the pan / rotate features stopped working. After closing and re-opening the applications, the left and upper toolbars had disappeared and I got the error message “Root element missing”. I’ve followed the instructions on My toolbars disappeared ! - Rhino V5 [McNeel Wiki] but it doesn’t seem to work. I also tried going into Tools > Options > Toolbars > Restore default but that didn’t work either. Not even deleting and re-installing Rhino seemed to help.

In case this might help I have the following plug-ins installed: Grasshopper, Weaverbird, and Lunchbox.

Common problem in Rhino V5.

First go to Options > Toolbars and see if the default.rui file is actually loaded. Most likely it is but all the toolbars have been closed. If so you will need to open the appropriate ones (Standard and Main) again.


If default does not show up in the window like the image above, then it is not loaded. First try File >Open and see if it shows up in the list of files to open. The normal directory is C:\Users\<your user name>\AppData\Roaming\McNeel\Rhinoceros\5.0\UI If it is not available to open via File>Open then try the following:

Via Windows explorer, look in the directory above and see if there is actually a default.rui that is present in that folder. If not, there should be a default.rui.bak file in that folder. If so, you can make a copy of that and rename it to default.rui. If neither of those two is there in that folder you should try a repair installation of Rhino, but if you already tried reinstalling, that should have also done it.

Once that file is present in the folder, go back to Rhino, go to Options>Toolbars and from the File menu open the .default.rui. That should do it.

1 Like

Thank you so much! I ended up finding the backup file through Windows explorer and it all works now.