Toggle Rhino/Grasshopper autohide and Escape Current Rhino Session

I think Rhino.Inside would flow a little better if the Rhino session didn’t always autohide when you click back into Revit. I find myself constantly opening up the Rhinocerous toolbar (in Revit) to show Rhino again.
Additionally, there doesn’t seem to be a way to exit Rhino. Even if you click the upper right x button, the geometry previews still show meaning it’s always running in the background until Revit is restarted.
Apologies if I’m just not using the tool correctly and these are non-issues.

Hey @jmarsh
We are working on the window-hiding issue and trying to come up with ways to make it work. The underlying challenge is making a non-modal window work with the Revit API

As for exiting Rhino, currently when Rhino is loaded by Rhino.Inside, it effectively becomes part of the host applicaton. It’s similar to Addons on Revit. Once an addon is opened and licensed, it can not be closed again.

The Geometry preview is coming from Grasshopper so make sure the GH definition that is showing the preview, is closed. See the top-right corner of your Grasshopper window for a list of open definitions.

Let me know if this helps.


Yeah, that all makes sense.
Today I had another issue. I had opened up my Revit project and launched Rhino/gh. I then wanted to open a new family and import the Rhino I had been working on into a family so that it could be face-based in the main project. I couldn’t get gh to speak with the newly opened family project, but instead it continued communicating with the original Revit project.

Try Grasshopper -> Solution -> Recompute when you switched to the family model. It should use the active document. Lemme know if it worked

Oh, that’s a good idea. I’ve done that before when my components were inexplicably orange or red and Recompute from with the Revit toolbar refreshed it correctly.

I really hope that this issue is solvable and will be solved.

Please, can we also make something about resetting panels also? Every time I reopen RiR all Panels are gone and this is insane. It really drives me crazy… Every time I got to bring back and arrange: Properties, Layers, Named Views, Display, Filter and more… I am starting to really like RiR and all of its growing functions but personally, I can wait for the new features, be happy with what I got now, but with this issue solved. After that, we can go further without this extremely annoying thing.

After reopen it looks like that:

Only Help Panel is there - very useful… and yeah I’m screaming for help right now. :wink:

Hey @Czaja ,
Rhino, when running inside a host, will create a custom profile for that host. In case of Revit 2019 for example, that profile is called Inside-Revit-2019 and the settings are stored under %APPDATA%\McNeel\Rhinoceros\7.0\settings for Rhino WIP

As a quick workaround is to open a command prompt or the Run window from start menu, and run Rhino while specifying this specific schema. See the example below for Revit 2019

C:\Program Files\Rhino 7 WIP\System\Rhino.exe /schema=Inside-Revit-2019

Rhino loads using this schema. Make all the adjustments you need and then close Rhino. It automatically saves all configurations into this schema.

Next time you launch Rhino inside Revit, it should look exactly how you configured it.

We’ll discuss this internally to see why Rhino is not saving configs when is being run inside the host.


And just like that, you made it for me. Thank you very much for that. :heart:

Some typos have appeared, this is the command which worked for me:

"C:\Program Files\Rhino WIP\System\Rhino.exe” /scheme=Inside-Revit-2019

Yeah depending on which shell you are using (cmd, powershell) you might need to wrap the path in quotation marks so the shell is not confused by the spaces in the path.

Glad this worked for you.

can I edit settings-Scheme__Inside-Revit-2020.xml file to save settings about units? can not find any value that describe it,

or I have to do it via a template ? I did this but seems selection is not saved

Hi Michal,

My understanding is that you have to do that via a template, yes.
Are you launching Rhino with the /scheme=Inside-Revit-2020 attribute?
When you then set your default template in Rhino Options > Files > Template files > Default, close Rhino and then launch it with that scheme again, the default template should be remembered.

1 Like

@wim thanks for your reply
I followed this step

run from command and adjusted

but when I open Revit 2020.2 it still opens with milimeters

even If I can see in files that template is in meters

so not sure why is not loading correctly or there is an additional setting I missed

When you launch Rhino 7 with that scheme, i.e. not in Revit, are the units then set to meters?

Yes correct, Rhino 7 WIP on it own is correct

In that case, @eirannejad will have to take a look.

1 Like

Hey @michaldengusiak

Would you mind opening the %APPDATA%\McNeel\Rhinoceros\7.0\settings\settings-Scheme__Inside-Revit-2019.xml file in a text editor and make sure it includes the lines below?

<child key="FileSettings">
    <entry key="DefaultTemplateFile">...\McNeel\Rhinoceros\7.0\Localization\en-US\Template Files\Large Objects - Feet.3dm</entry>

yes, I do have it,

  <child key="FileSettings">
    <entry key="DefaultTemplateFile">C:\Users\DengusiakM\AppData\Roaming\McNeel\Rhinoceros\7.0\Localization\en-US\Template Files\Large Objects - Meters.3dm</entry>

Okay it should be Feet then. Change the Meters to Feet to match the feet template. RiR again and the feet template should be the default.

yes but this is a bit confusing now,

  1. currently my files open as mm and not m , so it does not work
  2. I do not want to open template in feet as my revit is in set in meters and I want to be able to type data in meters, so I prefer to recalculate units **To/From internal units to meters and work with values I am familiar. I guess if I will draw some grid in Rhino I want to type 0.2 m and snap walls to grid.
    ** we need these two new components in Ribbon

Got it. My bad. I forgot we’re talking about meters. I can replicate the issue on my side now. Revit is in Meters but although the default Rhino is set to Meters, the actual loaded Rhino template is in millimeters.

Imma pass this on to @kike as he knows the Rhino internals better.

1 Like