Model Units change question

When I open the Revit model and Rhino.Inside and after some time will change Revit unit from m to mm I got this message. This all correct.

My question is do I need to go to rhino and change Units to Meters or I must save Revit in Meters and open again project in meter so Rhino will also be in the same units. Are both option safe?

image

Yes is safe to keep working with the units you like.
It is just a reminder that ‘1000’ in Grasshopper means ‘1’ in Revit.

Actually, @kike , I have found that mis-matched units can cause problems with Font families in Revit. The image below shows what took a couple days to track down; Rhino.Inside Revit was the only different thing introduced to the file & workstation during the arrant period.

Would it be possible for Rhino, when opening for the first time inside Revit, to detect the units (of the Active Revit file at the time) automatically?
Right now, no mater what units Revit is using, when Rhino opens, it is in Meters.

Hi @kevin3,

When Rhino.Inside Revit starts it opens the default template file you have configured here.

If you pick ‘No template’ Rhino.Inside will create a default document with same units, and tolerance values as the active Revit document.

Keep in mind that those settings may be isolated from the regular Rhino standalone or not, this is up to you.

Right now Rhino.Inside have no components to work with Font families in Revit.
Are you using a custom component that do so?
I’m interested to know why that problem happened to see if is something we can improve.

If you have more details, please let me know.

Yea, I was surprised too, how the units scale affected the fonts when printing.
I am not using a custom component…only out of the box RiR to modify materials only.

I’ll try to isolate a few key elements and send you a file next week.

Hi @kike ,
I tried today to isolate and reproduce the font size change and could not.
Printing to PDF is ok with either unit setting.

If I can expose the bug again I will send you some files.
Thanks for the details on template configuration!