There seems to be a bug with dimensions in the latest Rhino 6 version

Dimension is fine if I save the file in Rhino 6 format, but if I export it as DWG or Rhino 5 something odd happens.

Test DWG.dwg (30.0 KB)
Test R5.3dm (65.8 KB)
Test R6.3dm (68.0 KB)

It might still open correctly in other versions of Rhino. I tried to save it in Rhino 4 format and open it with Rhino 4. Rhino 6 didn’t display the dimension correctly but Rhino 4 did. Don’t have Rhino 5 installed so not sure if Rhino 5 displays the dimension correctly as well.

Hello - V5 shows the dimensions correctly as far as I can see and importing your dwg into V5 also looks correct. The dimension of the V5 file opened in V6 looks too small - the text, that is, not the value- - that is what you are reporting, correct?


Not exactly, here are a couple of Pictures. I can’t even see any text.

The Rhino 5 version has a long line extending off to the left when I open it in Rhino 6. Same if I save it as Rhino 4 and many other file formats. The dimensions are displayed correctly if you open the files in older versions of Rhino.

If I save it in Rhino 6 format (last Picture), everything seems fine.

Strangely enough if I open DWG or Rhino 5 files that I haven’t created myself they display correctly as well. So the problem only seems to exist when I save a file in a format other than Rhino 6 and open it myself in Rhino 6.

I open someone elses Rhino 5 file using Rhino 6, OK.
I open someone elses DWG file using Rhino 6, OK.
I save a file in DWG format and open it using Rhino 6, NOT OK.
I save a file in Rhino 4 & 5 format and open it using Rhino 6, NOT OK.

Might be something wrong on my end, some setting in Rhino 6 or something. But I don’t know what. Might be something wrong with settings for the text style I’m using, still it shouldn’t display it like that.

The problem might only appear when I overwrite the measurment with my own text. Remove the “<>” and enter my own measurement that is. Well that’s what I noticed in last file I tried to save.

Ok I’ve done some more testing, the issue only seems to occur when you override the measurement by typing something in the text box with the “<>” and save the file in a format other than Rhino 6. If you do that the text will disappear and some line will stick out in one direction after you reopen the file in Rhino 6.

I’m pretty sure this didn’t happen before the latest update. I think I would have noticed it before if it did.

1 Like

Since I got no further response I wonder if you understood what I meant? English is not my primary language, so I’m not sure if I explained it clearly enough.

If the bug is just on my end I want to know how to fix it.

Anyway, here is how to reproduce the bug.

  1. Draw a line
  2. Measure it.
  3. Override the measurement with your own text (replace the “<>” in the text box)
  4. Save it in Rhino 5 format.
  5. Reopen the file.

So I don’t know if others can reproduce the bug or if it’s just something wrong with my Rhino installation.

Exact same problem with me. Did a page of mixed scale drawings and over rode the measurements…saved as a dwg file for a collegue and oepened. Measurements were “corrected” didn’t save the overwritten dimensions.

Hello - I believe this works correctly now - There was a problem dealing with the <> in dimensions, and that has been fixed - I think it also fixes what you report. Your test above works correctly here- the over ridden dimension reads back in.