Another bug, similar to an earlier one


#1

Seems like there is a new bug having to do with dimensions.

In a previous version there was a bug with dimensions if you saved a file in Rhino 5 format and later reopened it in Rhino 6. I posted about it Here.

This was fixed in the latest version but it seems a similar bug was added instead. If I measure something in Rhino 6 and change the “Model Space Scale” of the Dimension Style and later save it in Rhino 5 format then the “Model Space Scale” setting stops working.

To reproduce.

  1. Draw a long line (well long enough that the default text size seems tiny)
  2. Measure the line and change the model space scale to increase the size of the text.
  3. Save the file in Rhino 5 format.
  4. Reopen the file in Rhino 6.

Now the dimension text should be tiny again, if you try to overwrite the “Model Space Scale” nothing happens, you can set “Model Space Scale” to “1000000” but the text will remain small.

Since I have to keep saving my files in Rhino 5 format so others (who don’t have Rhino 6) can open them I end up noticing these issues pretty quickly.

You can work around this bug by individually changing all dimension settings instead of altering the model space scale.


(Pascal Golay) #2

Hello - thanks, I see this.

@lowell - I think this is the thing we saw but could not reproduce, right? - it has to go through V5 format I guess. I’ll make a bug report.

https://mcneel.myjetbrains.com/youtrack/issue/RH-46535

@Mikael_Liback - it looks like for now at least, if you enable model space scaling in the file opened in V6, things will look correct:

-Pascal