Thea render plugin: Some noob questions

unhandled

#1

hi forum. i used brazil for years … in brazil the solution about my question was applying a material into the ground plane for catching shadows !

but now using thea, inside rhino as viweport, seems not possible the same thing,only using the standalone renderer.
there’s a solution? i think is so much easy using rhino and the viewport instead the thea render standalone

however…this is the model…i 'm trying to create a car, the first approach is to creare a simple plane for catching shadows,as if i use brazil…
it’s correct?
inside the standalone there’s an option to insert an infinite plane in which i can project shadows using a own property
but in rhino?


(Wim Dekeyser) #2

I don’t have access to that picture but it looks like Thea listens to the ground plane settings in Rhino. Just run GroundPlane and tick the check box.

It doesn’t look like Thea likes the default Rhino materials but I suppose you know how to handle that part…


#3

i just try that before,using the infinte plane of rhino but which thea material i must use after to make it transparent and achieve a plane with shadows?i use an HDRI background and i want that all brackgroud could be visible in the render viewport …including the projected shadows of my objects inside the scene!


#4

Agesandros,

I have found through trial and error that the Rhino plugin works much better and is far simpler to use than the standalone Thea Studio. The plugin has all the features of Studio. The ground plane you refer to is almost identical to the Rhino ground plane except that it will not use Rhino materials accurately. Be sure Thea is turned on and not Rhino in the Renderer checkbox. Shadows can be tricky with Thea. The distance between the model and light source(s) is a critica factor. I only use rectangular lights or sphere objects with different emitters selected. Play with the intensity and efficacy to adjust shadows. Use a basic white plastic for the ground. Contact Thea for additional help


#5

Create a new thea material, choose the material preset “Shadow catcher” and use that material for the Rhino groundplane.
I’m not shure however, if that works with a HDRI background.


#6
  • If you want an infinite ground plane that is visible, you can use the Rhino Ground as was said before and apply a Thea Material to it that is to your liking (concrete, asphalt etc.).

  • If you want an infinite ground plane that is not visible and only receives shadows while you still see the Thea Environment Background, the advice from Rallyman is correct, you apply a “Shadow Catcher” material either the way he described or via the Thea Material Editor where it is an option in the General Settings of the Material. This way you can also add reflections etc.
    The same works with a non-infinite rectangle with the same material, only make sure it’s large enough so you don’t see the borders.

  • What I also sometimes do is creating a large but not infinite rectangle as Ground Plane and then apply a Material to it that has a radial smooth white-to-black gradient in the Thea Clipping Channel. When “Soft” is ticked, you get a Ground Plane that fades out into the distance or into the (HDRI-) environment.

Thea for Rhino supports almost everything that is in Studio and I personally prefer it over working in Studio.

I hope this helps,

Tom


#7

ok thank you guys for all your support!


what’s the problem? this is what thea render last plugin offers as materials!
the shadows catcher mat. you are referring to ,is absent!


#8

  1. Create a new (empty) thea material
  2. select shadow catcher
  3. assign material to groundplane

#9


thank you people…for your suggestions!the new thea plugin has a new gui inside rhino, and find all the options was very hard for a noob! the only thing a was experienced in a bad way now is the grainy plane…


#10

If it’s too grainy, you need to render longer… :wink:
If the rendering stops too early when you use Production Mode you may need to increase the Samples Limit in the Thea Render Settings -> Termination to a higher value like 1024 or 2048 depending on your scene.

Also check what engine you use, for previews, Presto AO may be okay but I pretty much always use Presto MC, since that is the “real thing” (at least as far as GPU rendering goes).
EDIT: Just saw in your screenshot that you already use MC, so all is fine :wink:

Cheers,

Tom


#11

OK guys I think I solved my problem with ground plane.
What about decals? I can set them inside rhino? Or I must use the stand alone renderer?


#12

Rhino Decals are not supported yet in Thea 4 Rhino (I made a feature request and got the answer that they can support it and will do so in a later version). You need to use UV mapping for now.

Cheers,

Tom


#13

There is short tutorial on decals in the Level II training guide on page 174.


#14

is this normal?
i follow all your suggestions,applying thea mat. with cast shadows option enabled…but the plane seems visible in the render image…as black 50% transparent plane…see image below


#15

Do you use the HDRI in the Thea environment or on an enclosing sphere?
Looks as if something is throwing a shadow on that plane back there?


#16

HDRI or a flat image…it s the same!


#17

Hi guys!
last question
see image

  1. i put a material in the floor … what i must do for scale it? UV mapping,right? and if i want a square 50x50 or 60x60 woh can i set the material in the best way?
  2. the scene costs of a rustic kitchen, i put inside an HDRI for background and the same hdri for global illimination + rhino sun for direct illumination…but the opposite side of the room is complitely dark!
    how can i illuminate in a soft way that part ?

#18

Do you use the infinite plane or a large rectangle as floor? For the shadow catcher, you do not need any material (like basic) applied, only shadowcatcher activated.
If you want reflections, you can add a “coating” material.
I tried it here with a large rectangle and it worked well:

Cheers,

Tom

P.S. here is the scene, use your own HDRI in the Thea Environment to check if it works.
ShadowCatcherExample.3dm (143.3 KB)


#19

yes…that is physically correct!
a cube…a plane and shadows around


#20

1.) You can either change the UV mapping or you change the scale in Thea. For such a texture like the floor you may want to use a cubic projection. Open the Thea material editor (I don’t think you can access the finer texture details in the Rhino editor yet) and click on your texture, then you get to this screen:


There you can set the spatial size - default is 1x1 meter IIRC.
You can find all explanations about it in the Thea Documentation.

2.) Are you using Presto AO or MC? What is your raydepth set to? Do you use a thin-glass material on the window (“thin film”)? Hard to debug without seeing the scene…
But always remember that this is physically correct rendering - if you push a lot of light through the window, the rest of the room may simply be dark in comparison to the hot spots. Would be the same if you took a photo of the same room.
So you can try raising the ISO of the render, which may lead to blown out highlights in this case…

I would really encourage you to check out the docs for Thea and in the Thea Forum, there are also a lot of tutorials available, for instance here: https://thearender.com/forum/viewforum.php?f=16
There are more Tutorials available but they are in the licensed user area.

Cheers,

Tom