The document ".3dm" could not be saved

I am having issue with a file or set of files now because it wont let me save it and it does not autosave it either, so every time i want to save that file I have to export it and save it with a different name but once i open the new version the same issue persists.

I have had that issue before but then at some point it stops happening.
I have it saved directly on my google drive local folder.

As a test, what happens if you change your process a little.
Save your files in another local folder that is not monitored by Google drive. Then when you’re through modeling for the day, copy the files using Finder into the Google Drive folder.

Does that eliminate this problem?

My guess is Google is syncing the folder and has it temporarily locked at the same time you’re trying to write to it.

Any luck?

So, it wasn’t letting me do anything to it; I couldn’t save it I couldn’t revert it, I couldn’t simply close it.
Earlier I had restarted my google drive file stream and it worked at the beginning but it happened again.
I got this message afterwards:

Now I tried what you suggested and it is working fine but we’ll see how it works later on. To be honest, this has happened before and at some point it just stops doing it but I do think it is some kind of issue with the file stream, some files do it and others are fine. My usual way around it, as I remember is exporting all or in pieces and like i said at some point it gets fixed.