Texture mapping

Hello, i am trying to map a texture i made in photoshop and use as jpeg file on rhino 7. When i move the texture in mapping tool its resolution drops too much. I didnt have that kind of problem in rhino 6 but in rhino 7, it doesnt work or i couldnt make it work. I am attaching pictures to illustrate the problem.
This is how it looks before clicking apply on mapping interface.

This is how it looks before clicking apply on mapping interface.

Hi @karakusc
I had the exact same problem and posted about it here a month ago - got no answer :grimacing:
Hopefully someone will chime in with a solution!
-Jakob

Hey, i just found it by myself. After mapping, just increase the mapping channel under the metarial options. I hope it helps to you too!

1 Like

You are indeed right, @karakusc! I wonder if anyone knows the reason why? I was never much of a texture-wiz and have no idea if this is expected behaviour or not…
-Jakob

But… If the mapping channel on the material is set to 2, the texture doesn’t show up in Raytraced, only rendered viewmode…
@nathanletwory - I know Cycles is your domain. Can you shed some light on what’s going on here.
TIA, Jakob

Are you still on an older Rhino 7 version? I fixed this in Rhino 7.5:

Diffuse texture on channel 2, transparency texture on channel 3.

i have updated my rhino yesterday but mapping still works strangely i dont know why. For now, i just save the day anyway:)

I don’t know about the uv editor in this case, @Jussi_Aaltonen can tell about that more.

Probably somehow related to usage of ATP (Advanced Texture Preview), or lack of usage of ATP. I generally don’t worry too much about it, I’ll just handle the data that’s handed to me in Raytraced (:

:laughing: Fair enough!

Sounds like a bug. Filed as RH-63882 Texture mapping issue

Might be, but changing the channel works for now.

Hi @karakusc, sorry for a late reply.

After you click Apply on the UVEditor that object will have so called custom object mapping
image

Surface, polysurface and SubD objects that have custom object mapping use Advanced texture preview in order to preview the mapping correctly. Advanced texture preview uses texture baking which in many cases lowers the texture resolution seen on the object.

If your object has only one mapping channel and you define a texture to use channel other than 1 then the result will be undefined and depends on the display mode or renderer. In this case it appears that Advanced texture preview gets disabled for that object because the mapping channel 2 assigned for the texture does not exist. I encourage to avoid that trick because it may break your model in any future Rhino update.

I suggest you try one of these:

  1. Apply your texture using cylindrical mapping
  2. Add your ornament to the object using a cylindrically projected decal
  3. If neither of the above work turn Advanced texture preview off temporarily from the display mode settings. Remember to turn it back on or you may experience other more severe texturing issues with other models.

@Normand The above answer may also be of interest for you.

Hello, thank you very much for responds and advices bu i couldnt understand what i am suppose to do with that one " 1. Add your ornament to the object using a cylindrically projected decal"

Hi, there are some tutorials available in Youtube. Here’s one that shows how to apply decal with planar mapping: Rhino 3D Tutorial: Decal / Logo Texture Application - YouTube

By “cylindrically projected” I meant the cylindrical mapping style for the decal. It is useful to add a vertical guide line in the center of the bowl to make it easier to pick the start and end of the cylinder.