Ray Trace Ruining Texture Map


I’m trying to render an image in the RayTrace view, but the texture mapping I’m using gets warped and stretched despite being set in Perspective view. Why is this change happening? How can I fix it? If not, is there an alternative to rendering an image to the same quality?

With what Rhino version are you seeing this (Rhino command _SystemInfo, paste the contents).

Further, screenshots and a 3dm file would be necessary to further see and understand where the problem comes from.

Here is the System Info, I think I should also say that I am fairly new to Rhino. I have been needing to use it for school assignments, so I may be lacking in some basic terminology.

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Evaluation, build 2020-08-25
License details: Cloud Zoo. In use by: Amanda Rosario ()
Expires on: 2020-12-01

Windows 10.0 SR0.0 or greater (Physical RAM: 12Gb)
Machine name: LAPTOP-MABM89CA

Non-hybrid graphics.
Primary display and OpenGL: Intel® Iris® Plus Graphics (Intel) Memory: 1GB, Driver date: 4-22-2020 (M-D-Y). OpenGL Ver: 4.6.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build
Driver Date: 4-22-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

If you still could share the 3dm file I can see better what you’re doing and where it goes wrong. If you don’t want to share it here publicly you can use rhino3d.com/upload?to=nathan@mcneel.com . I’ll be automatically notified when the upload is ready for me.

I sent it through the email. I’ll keep an eye out for when you respond there. Thank you!

Looks like baking the textures is failing here. Baking is needed because you have complex multi-channel mapping set for objects. In most cases I believe you should be able to get what you’re after with simple 1-channel planar mappings.

I’ll check with @Jussi_Aaltonen to see how to solve this.

Hi @naniamr413, it appears that something has damaged the surface parameter information on many of your surface render meshes. Try running the _ClearAllMeshes command and then switch back to Rendered mode and then to Raytraced mode. ClearAllMeshes destroys the render meshes from all surface and polysurface objects.

Also some of the surface are missing mapping channel 3 and the layer material uses it (for example the surface on top of the highest part). In those cases the results may not match between different display modes and render plug-ins.

I’m interested to know how you created those surface because it seems there is something corrupting the surface parameters on render meshes.

The ClearAllMeshes worked! Thank you for your help!

Good to hear @naniamr413 :slight_smile: Any change the creation of those surface would still be in your recollection?