Texture mapping, multiple issues


#1

I am having a lot of issues with proper texture mapping. I have watched this video to get a better understanding of this: https://vimeo.com/58457893, and https://www.youtube.com/watch?v=u01F7HpKqMo as well as several others.

Am I correct to understand that a lot of widgets, icons, commands have not been implemented yet in the RhinoMac version for texture mapping? It seems that several things are still missing in the Mac version.

This page http://docs.mcneel.com/rhino/5/help/en-us/properties/texturemapping.htm, shows icons that I cannot find in the current version.

This is a screenshot of the second video.

Or I can’t find them if they are present.

A help topic for this does not seem to have been documented yet either.

When I look at my object in Rendered mode, it looks pretty bad.

And after rendering it looks a lot worse.

I am able to turn the MappingWidget on, but I can’t figure out how to turn it off.


(Brian James) #2

Mac Rhino won’t have custom unwrapping or the Unwrap command. It also doesn’t have the same UI as Windows Rhino. The only texture mapping controls visible in the UI are in Object Properties. Everything else will be accessed by commands. By default the mapping is by surface UV. For this case I’d use Box mapping. However, this isn’t working perfectly here at the moment and I need to file a few things I’m seeing. Then use MappingWidget to show the box mapping widget and adjust it with the gumball. MappingWidgetOff turns the mapping widget off.

Post a file and the texture if you want more help and I’ll take a look. The texture mapping controls in Mac Rhino (at least for the release) are essentially those found in Rhino v4.

I’ll make some tutorials after everything is working as it ought to… it’s still a WIP.


#3

This seems different in my version of Mac Rhino. In the Render Tools tool palette you can open the Texture Mapping tool palette, which has several texture mapping controls. I haven’t yet figured out how to use the settings in the Object Properties panel, like position, rotation, size and UVW settings.

I discovered that there is a mistake in Texture Mapping palette. When you hover with the mouse over the second to last icon in the Render Tools tool palette it shows for left click “Show mapping widgets”, and for right click “Hide mapping widgets”. However, when I right click it does not hide mapping widgets, it opens the Texture Mapping" tool palette. Show mapping widgets works fine.

I am well aware that the version(s) of Mac Rhino I am working with are WIP, and I am thankful that they work as well as they do. My questions are in no way meant as criticism. Because of my lack of deep knowledge of Rhino as well as lack of experience with it, I often don’t know if something is missing because it has not been added yet, if it is a bug, or something I am doing wrong. This is one of those cases, although I am somewhat certain that I am correct about that wrong right click I found.

I was also under the impression that McNeel would want to know if we find things that seem odd or wrong, since that is the point of beta software. I like the fact that I am able to contribute to make the release as good as it can be. I have found a few things that have been added to “the pile”.

As you requested, I have added the file as well as the texture I used.

Machined Ring #4.3dm (344.9 KB)


(Brian James) #4

Thanks for bringing that up, I wasn’t aware those icons were there. I found some more bugs as a result!

That works to hide a selected mapping widget here in 5A783w. Are you using the latest WIP? Also, is the mapping widget selected when right clicking this icon? I’m seeing Hide work too to hide the mapping widget, out of curiosity, does that work for you?

I didn’t take them as criticism. Please mention anything you think is wrong in the WIP.

I’m able to hide the mapping widget with the right click over the icon or with the Hide command. I’m not sure what’s different in your workflow but check that you are running the latest WIP and that the widget is selected. I also noticed that the mapping is currently set to Planar and the texture used is not tileable, both of these factors will contribute to how the texture looks on the model. Box set to a size of 25x25x30 via object properties would be best here but that isn’t working perfectly yet, I believe it has something to do with the caps of the box not being calculated properly. I filed an issue for the developers to look into yesterday regarding that. The last thing I noticed is that you have an environment map texture applied in your material. I’d remove that as a test to see if it is causing any issues.

Thanks for reporting what you’re seeing, make the image tile and then give it a box map for the best result currently possible.


#5

I am also using 5A783w. I am also able to hide the widget with a right click over the icon as well as the regular Hide command. After reading “Hide Mapping mapping widgets” when mousing over that particular icon and then when right clicking the Texture Mapping tool palette showing up, I never checked further, … my bad. It does seem that something is not quite right here though.

What makes a texture tileable? And if a texture is not tileable, can it be made tileable?

I set the Projection to Box in the Object Properties panel as you suggested. Why is this done in the Object Properties panel and not with the “Apply box mapping” icon in the Texture Mapping tool palette? That is where I went intuitively.

I also did this. The rendered object looks much better now, albeit still with a number of issues.

Why did you pick 25 x 25 x 30? for the size. The object itself measures 20.80 x 5.00 x 25.80.

I played around with removing the environment map and keeping it. When doing this I needed to tweak the numbers for both the texture map and environment map file a bit to achieve the result I liked the best. I finally liked the result with the texture map intensity set to 40% and the environment map intensity set to set to 15% the best. But that is probably just personal preference.

Since environment maps are best used when working with reflective objects and the object in question is supposed to be brushed stainless steel with a limited amount of reflectivity, the use of an environment map is a toss up.

Either way, the rendering looks a lot better with the setting applied that you suggested. Thank you very much.

Of course as soon as I show all my lights again, everything changes again. :smile:


(Brian James) #6

If a texture repeats without a seam shown, it is tileable. You can do this in most 2D editing programs or use a program that specifically makes images tileable. There are lots of options out there and tutorials on the subject.

Both will work… some users think one is more logical a workflow so both options exist.

So that the texture looked more evenly scaled in all directions and the portions of the image such as dark areas that interrupt the tiling aren’t as visible.

Emaps in materials are going to override reflection. Use an HDR in the background or skylight instead.