Technical drawing make2d scaling

I have A4 size technical drawing base. My model is too big for that size after make2d.
My question is, should I:

a) scale make2d curves smaller to fit A4 drawing or
b) scale my base drawing bigger to fit to make 2d curves ?

I have new layout view and my A4 base fits great there now. If I scale base, layout does not fit anymore.
If I scale curves, my dimensions are not correct anymore. Which settings I have to change to get correct dimensions after scaling curves? Is it possible?

I’d like to hear how you have solved your technical drawing things…

Thank You allready Rhino family :slight_smile:

Hi @Wagner,
In Rhino we have two places:

The model space, where we model our 3d objects/2d curves. In this place everything should be at 1/1 scale, which mean that if you have a 10x10m house, and you mesure it with the distance tool, those are the values you should get.
In this model space, you can also generate drawings from your 3d objects using Make2D as you already did. There are two kinds of outputs generated by Make2D, parallel views and perspective views. The former should also be at 1/1 scale, and you should make sure of that by using the distance tool after running Make2D and scaling accordingly in case the result wouldn’t match. Then, we have perspective views which don’t have scale and you shouldn’t be worry about how big they are because you will solve that in the next step.

The layout space is where we produce and compose the drawings on actual pages, in your case A4. The link between model space and layout space are details and you can have as many as you want on a page.

Neither of those, you shouldn’t scale anything if everything is 1/1 as we did in step 1. The way you solve this is by adjusting the scale of the detail. So, you have your base properly adjusted on the A4 and now you have to place your new curves from Make2D on that page. Create a new detail by using the _Detail command and draw the rectangle, then select the outline by Left clicking on the outline once, and in the properties panel adjust the scale until your drawing fits properly

Does this help you? If not uploading a file would make thing easier to understand and solve.



Hi Jose!
Thank you for your extensively informative answer!
I got it to work after some training :slight_smile:

Thank you one more time!

1 Like

One more detail :smiley:
I moved my base from top view to the layout. I think it works well now.
I’d like to draw dimensions and leaders there also. I did it but I noticed that if I change the view by zooming or dragging, dimensions does not follow…
So I had to make all details (dimensions, leaders etc) to top view. What I noticed that top view details are very tiny but in layout looks nice sized. Why this? Where to change? It is difficult to use top view with so tiny detail, have to zoom alot to see… I scaled all dimension in options and top view looked good but when I went to layout, there were huge details…

Hi Wagner -

Which version of Rhino are you running? The dimensions should follow the geometry. And dimension scaling shouldn’t be an issue.

Using Rhino 6.

Ok, I got it…
It updates (moves to the correct positions) the dimensions after clicking back to “grey” /closed detail.
I moved and zoomed and when it did not move the dimensions to the correct places I deleted them.
I was too quick :smiley:

Still have to make 2 different dimensions, one for model space and one for layout. I can live with that :slight_smile:

Talking about dimension, when using model space and dimension… If I use Gumball rotate, it looses the corners and gives the result 0… Not sure if it worked earlier like that… I think it can’t change dimension from vertical to horizontal…


They should update, the dimensions, even if you move your objects in model space. But I prefer to annotate everything in model space. Look what happens when you move the dimensioned object next to the edge of the detail.

Are you talking about the values associated to dimensions and leaders, that you are seeing them very tiny in model space but ok in layout? This is because you have activated enable model/layout space scaling. Here a screen shot of the Annotation Style (Mac interface, in windows is different but works the same)

No! You shouldn’t have to annotate twice! Just change the model scale factor as I explained previously.

I don’t understand this part, could you elaborate on this?

Keep trying, you are really close!

Wow I really appreciate your help!
Model space scale worked great!

Gumball rotate to the basic rectancular box with linear dimension does not work.
When gumball copy and rotate it works, weird…
R5 worked normally, what I tested…

Nothing serious…

I’m so glad I got my “problems” fixed!

I’m glad that it worked!

Instead of using linear dimension use Aligned Dimension.