Regarding importing autocad 2d drawing (Issue of Scaling)

I imported 2d drawing from autocad which were in mm, while importing in rhino, as usual it poped up windows , and asked for units and scaling, i changed it to meter by mistake.
Now my 2d drawing which were in mm in autocad, after importing it in rhino, they are multiplied in size by 1000 and still they are in mm.
And i noticed my mistake late.
So can i get my original size back (means,(divide by 1000)) now at this later stage…Is it possible ?

And my geometry is complex, so i cant use scale command.

Is there is any other way or command which can reduce size of my geometry by 1000(Meand divide by 1000)??

Thanks

Why?

-Pascal

Actually…my geometry contains lots of parts (It’s assembly)
And to resize every part individually…it’s hectic.

Hello - try: select everything, start Scale, set the base of the scale at w0,0,0 and type in .001 and Enter…? Done.

-Pascal

Make sure all layers and sub layers are turned on and unlocked, and nothing is hidden before using selecting everything.

Thanks Pascal.
Doubt for me was actually I designing a boat and it has 23 frame structures and lot of other things like pilot seat,crew seat etc.
So because in my imported drawing everything is scattered all around , so I thought its not possible apply scale command individually…thanks

I want know one more thing…in rhino, how many coordinate system are there…like world coordinate and any other more??
Thankyou

You can inverse the procedure:
DocProperties>Units, change to meters. Answer Yes to the scale question.

The whole file will scale by 1/1000, including hidden and locked layers/objects.

Then again

DocProperties>Units, change back to mm. This time answer No to the scaling question.

You should then have the right size in mm.

hello…thanks…I cant find Scaling question.
I attched the snapshot after entering DocProperties>Units.

Can you elaborate…where is that thing.(I attached that window )

Thanks

thanks…david

It’s the next screen you will get after you hit OK…

image

thanks…in my case after following your procedure,Value didnt change, still it is multiplied by 1000.

i even tried by creating new drawing, and just examined for one single 1 meter line…but value remain same

Say you had a file to import in millimeters with an element that was 1000 mm long.

You import that file into a Rhino millimeters file but you told Rhino that the original was in meters - so Rhino scaled the import by 1000 and the object becomes 1,000,000 millimeters (1000 meters) long. That’s your current situation now as far as I understood - you model is 1000 times too large and in mm.

Now, you ask first to change the units to meters, and you answer YES to the scaling question.

Your object will now be 1000 meters long (the file units are now in meters)

Now, you ask to change the units to millimeters again, and you answer NO to the scaling question.

Your object will now be 1000 *millimeters * long (the file units are now in mm) i.e. now the correct size.

I guarantee you if you follow the above procedure exactly, you will end up with the right scale object.

Thankyou…i will chceck again and let you know…thanks for kind explanation

Thankyou Helvetosaur…i was not able to check it immediately…today i applied your process…it worked 100% correct.

thankyou for valuable trick.