Scaling + Dimensions

scale
unhandled
dimensions

(Mitchel Given) #1

So, I try to scale a project from 1:1 to 192xp and my dimensions now display huge. After using ‘scale’ I try to put my dimension ‘_options’ so they’re readable but my measurements are way off. I put a test file here one measurement should be 18’ now after scale 1/192 it measures 1 1/8".

Is there efficient way to scale and keep measurements the same as original drawing?

Test.3dm (109.8 KB)


(David Cockey) #2

Are you using Scale to change the size of objects in a drawing? That is usually not a good idea.

Instead try changing the output scale in Print.


(Mitchel Given) #3

Thanks for reply. I scale all my work after make2d then export to ai (add misc, renderings, etc…) then print to pdf then plot. I never use rhino print.

my order: make2d > scale:xp > export:ai


(Pascal Golay) #4

Hello - you get to set the scale in AI export - have you tried that?

-Pascal


(Mitchel Given) #5

Hello, I try that but ai crash when I try to move the drawing. Sometime error: “Can’t move the objects. The requested transformation would make some objects fall completely off the drawing area.” when the exported rhino file is outside illustrator viewport.

If I do my method make2d > scale > export:ai 1:1 I have no problem.

I like using _scale Alot cause I know I get true scale. But dimensions are not happy.


(Wim Dekeyser) #6

You could try exploding the dimensions before scaling so that they become mere curves…


#7

First thing, you should not work in pixel in Illustrator, “inch” is the universal print unit and is a good choice since you want to print. Trying to convert inches to pixel seems to be a non sense to me while converting inches (or millimetres) to inches (or millimetres) is the way to go.
Second thing: Do not scale.
A good way to always get the good size is to use the ai export “preserve model scale” option and to avoid any scaling within Rhino.
Depending on the type of objects to deal with (furniture, truck, boat, yacht, building)… One little calculation to get the perfect ratio between illustrator and rhino layouts and voila.
In your case your layout is 5 inches x 5 inches and is a small object and 1 inch = 1 inch will give the good result.

Third thing: move the 0,0 point to the base of your drawing, this way it should stay within the illustrator workspace. Or use the command export with origin and set the origin to one of your object corners