Surface transparent - bug

Is that due to the building curve or how do I detect issues errors with this surface and how to fix this?

happened many times in the past.

Thank you!

Export N Surface.3dm (150.6 KB)

Even Rebuild Surface would have no effect on this transparency

99% of the time when surfaces “go transparent” it is because you have bad trim curves. This is no exception, but it takes a little looking to find the bad spot(s). Here is the one problem spot:

Zoom way in:

Fix the curve this way (move cp upwards a bit)

Make a new planar surface and you get:

1 Like

So good. Thank you for this information.

Mitch, do you think this is worth a feature request, to have a function to check geometry for bad things/issues that occur during operations like the dots that are created when boolean operations fail.

Thank you for your opinion on this.

Would be very handy for everyone to have it working probably as a repair command — in Modo they have a command that handles all of the issues (flipped polygons, duplicates overlapping geometry, holes I guess…) — it’s called “Mesh Cleanup”

image

Sure, I think the main difficulty is determining where the problem is exactly. Your letter for example was a self-intersecting curve. But the self-intersection was far below the file tolerance in size. However, even if you reduce the file tolerance, Rhino’s self-intersect detection still does not detect it. Normally if a self-intersection is detected when you ask Rhino to make a planar surface, you will get this warning:

image

Incidentally if you run CurveBoolean on the curve, it will also cut off that little loop, and if you make a surface from the fixed curve, it will then shade.

In your case, it actually made the surface without warning you about the self-intersection (because it wasn’t detected) , and the result was even considered to be valid. But Rhino’s mesher failed to make a render mesh for it, hence it was transparent (no render mesh). Perhaps a warning message could be created when a surface fails to mesh. But if you work in wireframe, the mesh is not made immediately, it is only created when you turn on a shaded mode. It may be too late by then.

Thanks, Mitch, for explaining this in-depth. Understand now! Will use CrvBoolean in any future case to tackle this.

Thank you!

Letterforms are notorious for being bad curves to make surface or volume geometry from. Generally they are made with Illustrator-style programs which throw together a connected collection of Bézier splines without regard to continuity at joints, quality of the curves etc. Nobody really cares about this because they are mainly intended for print or on-screen display purposes. As soon as one starts to make surfaces from them however, the problems show up.

That being said, the curve in question should have been flagged as self-intersecting, but wasn’t. I will create a bug report for this.
https://mcneel.myjetbrains.com/youtrack/issue/RH-73966/Self-intersecting-curve-not-detected

1 Like

This N was Neue Haas Grotesk which is the predecessor of Helvetiva, which is actually Helvetica if you are not zooming in.

Thought this is a standard font.

Well, despite its heritage, it does not appear (for the “N” at least) to be of Swiss quality… :stuck_out_tongue_winking_eye:

Seriously, even the most used fonts have problems, I am not even sure if the software packages used to design them have the tools to make good NURBS curve geometry. That just seems to be the way it is…

Accepted :slight_smile:

RH-73966 is fixed in the latest WIP