Rhino bug maybe?


#1

A friend of mine made a surface using the ‘curve network’ command. However when she switched the view from wireframe to rendered it doesn’t show up, only some parts can be seen, around 5% of the total surface area.

Her model has no straight lines and has an organic shape.

Does anyone have any idea? If you have any please reply as soon as possible. Thank you for taking the time to read this. :slight_smile:


#2

looks like a “Bad Object”

If you select it and run the Check command you should get more details.


#3

It says that the surface is valid and there are no errors. Do you have any other ideas?


#4

Can you up load the surface?


#5

I hope that you’ll have some ideas on how to sort it out. Thank you in advance! :slight_smile:

model with window v1.3dm (1.8 MB)


#6

Run the Rebuild command on the ‘curvenetwork’ item, increasing the points in the U direction to 13+; it just needs more points to display correctly.


#7

Here is the link how I fixed this.

http://www.screencast.com/t/vVLqiUgC7zj4

I think the cause was the way the surface was being trimmed.


#8

Thank you so much! Both her and I really appreciate your help! :slight_smile:


#9

It’s so freaking nice of you to even give it a go to fix it! Wow, you’re really cool! :smiley:
Thank you so much for helping us out!


(Pascal Golay) #10

Hi Danny - usually this type of shading defect can be fixed by retrimming the surface. In this case, select the surface and Invert Hide - this will isolate the surface - I guess you need to turn off any locked layers as well for now. Start UntrimAll with nothing pre-selected and select the surface- use the same curves to split or trim the surface again and it should look OK.

It looks to me like the trims from the objects on the layers ‘Interior w 1’ and ‘useful area’ are the ones causing the trouble, I’ll see if I can reproduce it here.

-Pascal