Surface not showing up on shaded or rendered mode

I’m trying to create a topographic map for a class. I have the lines outlining each contour, so I just need to make these into surfaces and extrude them to have my 3D map, in theory. The first few levels work, but frequently the surface doesn’t show up correctly. I’ll use the planar srf command, and if I select the boundary of the surface it gives an option to select the surface, but there’s no surface visibly there. If I try to extrude it, it acts as if I’m extruding the curve boundary but doesn’t treat the extrusion as a solid. I’ve tried a few methods, including bounding the regions and using PlanarSrf and creating regular surfaces and trimming them with the contour line. I’ve also copied the lines into a new file, in case the old file was corrupted. Every time, some of the surfaces will show up, and some won’t. Has anybody had a similar problem, and any ideas how to fix this?

Hello - most likely, there are small loops or self-intersections in the curve - can you post just that curve and surface?


surface issue.3dm (178.6 KB)

Hello - thanks, yep - little loops:


secret weapon: testIntersectSelf


Thank you so much! I’m still pretty new to this and was getting very stressed. I’m still having trouble though- I used the command you suggested and got rid of the loops, but with the same result. It’s a different curve, but from the same file and with the same issue surface issue2.3dm (111.9 KB)

Yep, I see - the command misses the loop in this case - it is very very tiny. Here is another less secret weapon : CurvatureGraph
If you turn on CurvatureGraph for the curve it will initially look like a bad trip but if you turn the scale down to 85-90 you’ll see most of the graph gets out of the way but where the loop is is a crazy piece of graph.

Zoom waaay in there

The other places where the graph is still big are zig-zags that you might want to clean up but not, I think loops.


1 Like

Wow, thanks again. I didn’t realize how many loops I’d accidentally created. You don’t happen to know a quick way to fix them, do you?

maybe with RebuildCrvNonUniform :

Hello - usually you can just move or delete a couple of control points.