Sweep 1 Rail is blowing my mind


#1

Running Rhino OSX.
The model on the left is giving me what I want as far as the shape. I modified the cross sections by adding a slight curve to them and filleting the corners. I tried doing one at a time to see if one was throwing my sweeps off. They are both not producing the same result as seen in the first model.

I know I can fillet after the model is created but what about the curves any way to deal with that??


(John Brock) #2

HI
Can you please attach the 3DM file including both Sweeps and both sets of curves you used to create them?
Thanks


#3

Updated


(John Brock) #4

I think the problem is you aren’t being consistent with the seam location and “Roadlike” setting. This could be because you’re likely working in the Front view and can’t see the importance of these settings.

You want to bias your pick of the profile curves so Rhino guesses which corner to run the seams through. Also, because of the orientation of your curves, you will want to use Roadlike Front so they don’t flip around.

I’ve included a simpler example of two very different polysurfaces created with the same two rectangles, but shifting the seam to illustrate what you’re seeing.


#5

Alrighty I figured it out… You have to play around with those arrows right after the command has been finished. Is that what you meant with seam location?


(John Brock) #6

Ayup.
The white line is the seam location and the little arrows are the direction the surface will swing. Play around with a simple example line the rectangles and a line between them to figure it out.