2 Rail Sweep Doesn't Connect


#1

I swept a curve 360 degree between two rails. The resulting surface will not boolean union with the closed poly surface I’m trying to mate it to. When I do a ‘shownakededges’, it shows that I have openings. I’m not sure why or how to fix it. It’s been awhile since I’ve been here so am a bit rusty.

Uploading the file…Tailpipejointry2.3dm (2.7 MB)


#2

You’ll have to explode and trim the polysurface with the sweep. Then join them to create a new solid. I think you’re better off just doing a new revolve.


(Alexander Petrov) #3

My advice! Project a curve over the model, the starting point of the curve should be the center of the object. Then make a profile with all ellements, and make a nother swepp. Tailpipejointry2.3dm (157.8 KB)


#4

Are you saying that doing a new sweep might fix it? I tried that a couple times. I had a previous version with different dimensions and was able to do the union after the sweep, although it gave me a message asking if I was OK loosening the accuracy.

Tried the trim as you suggested. It worked on the lower edge, but not on the upper. I’m going to try shrinking the upper rail and get the sweep to embed.


(Pascal Golay) #5

I think just make a Revolve (Surface menu) not a sweep at all, of this curve:
image

-Pascal


#6

Oh, nice; thanks Pascal.