Substance material just grey in Rhino

I’ve imported a Substance Oak Parquet Floor material into Rhino but it just shows up as grey. It looks like Oak in Substance Designer and Substance Painter though. Other Substance materials have come into Rhino fine.

There is a huge number of parameters associated with this material. Any advice on how to go about trying to find out why it isn’t working would be very much appreciated. Rhino 7.8.21168.1001, 2021-06-17, with Substance Importer 2.0.0.


1 Like

Updating the Substance Importer plugin to 2.0.1 fixed this.

Indeed the correct fix is to update to 2.0.1 :slight_smile:

Some behavior in code changed that worked fine up until 2.0.0 + 7.7. We are not sure what changed and where exactly - Rhino or .NET framework, but @lars found the fix which he could do in the plug-in code.

But you now need to dial out the default height settings, otherwise:

Could you send me the model please.

Sure, here you go:

SBSAR Height Issue.3dm (14.3 MB)

Default values in question are Height Range: 1.0, Height Position 0.5. Setting Height Range to 0 places the material on the surface, by 0.1 it is coming off at an angle.

I only downloaded this material on the weekend. It is very heavily parameterised and I haven’t yet sussed out the effects of most parameters.

Hi @jeremy5
You need to convert your extrusion to a polysurface - the lightweight nature of extrusions give them a render mesh not suitable for displacement. Convert it to a polysurface and give it a fitting custom render mesh - then it should work. Or disable then displacement :slight_smile:
HTH, Jakob
EDIT And also the scale of things - your box is just 30mm long. I’m guessing the displacement settings in the sbar is made to real life units (probably 1000x1000mm floor or something like that), so either scale the box or scale the displacement settings.

Hi @Normand,

Extrusions - yeah, I’d turned the “use where poss.” option back on to check out something on Discourse and neglected to turn it off again: my bad. But I still see unhappy artefacts with a (larger) polysurface:

In fact going up to a 2m cube there are still issues unless, as I said originally, I dial down the default height settings. Could you share the settings you used for your cube?


Hi again, @jeremy5
Not at my computer, but basically set a custom render mesh with all settings at 0, except max edge length, which was set to 0.5mm - also make sure to uncheck Refine Mesh and Simple Planes.
If it’s still causing trouble, I’ll provide you with a screengrab/file tomorrow!