SubD is not smooth and is faceted

example.3dm (1.8 MB)
is there a reason why my subds are looking so low res and faceted? I cant understand why they dont appear smooth as in shaded view. It is making it quite difficult for fabrication.



Maybe Flatshade is on?

no when i export to stl,obj,or step thats how it looks also

You can adjust the quality of the mesh that you export. Is that what you are trying to do? Your subd is smooth (as you show in your shaded view.) It looks fine here. When does it appear faceted?

I quad remeshed at around 1,000,000 quads and also cranked the stl all the way up the mesh when i reimport or try to slice looks like the image above

… where?
Which other software show your mesh as faceted?


It definitively looks you toggled faceted mode:
2024-04-16 03_41_08-Window

one sec while i load in in bambo to show you

quad remesh with 5M faces then split it for my plate-- still looks like this in bambo no matter STEP (straight up polysurf from rhino no meshing) or obj/stl

can you upload the starting file?

which? the subd or the mesh/step?

anything to help you.
The subd maybe?

Why are you using quadremesh?

I assume bamboo meshes your step file for you, so maybe look at the settings in bamboo.

The subd is in the first post.

im saying that ive tried STEP and ive tried manually meshing-- quad remesh looked cleaner than the regular but i will upload the mesh settings to show you i cranked it up to the max
example.3dm (1.7 MB)
basemetal.stl (12.4 MB)

ops…

This is the output of the subd from the first post, seen from Meshmixer software.

ok well i cant understand why why i mesh it or export the step it looks like the image i attached from bambu
my prints are all faceted

Everything looks perfect here. Maybe your subd model is too far from the origin, but it looks really ok here.

Are you exporting in .step format?
If so. Don’t.

SubD > .3dm Rhino format
Mesh > .stl or .obj

What “step”? Where? Avoid so.

what did you export to get it like that i attached the mesh settings i used

Simple normal export, default settings.
2024-04-16 04_00_48-Window
I’m exporting the subd directly, it is converted into a fine mesh during the export.
Only the bottom slider is relevant here.

1 Like